summaryrefslogtreecommitdiff
path: root/dev-cpp/doctest/doctest-2.4.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-cpp/doctest/doctest-2.4.9.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-cpp/doctest/doctest-2.4.9.ebuild')
-rw-r--r--dev-cpp/doctest/doctest-2.4.9.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-cpp/doctest/doctest-2.4.9.ebuild b/dev-cpp/doctest/doctest-2.4.9.ebuild
new file mode 100644
index 000000000000..fa60bdec8854
--- /dev/null
+++ b/dev-cpp/doctest/doctest-2.4.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="The fastest feature-rich C++11/14/17/20 single-header testing framework"
+HOMEPAGE="https://github.com/doctest/doctest"
+SRC_URI="https://github.com/doctest/doctest/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDOCTEST_WITH_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}