summaryrefslogtreecommitdiff
path: root/dev-cpp/curlpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-18 02:09:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-18 02:09:39 +0000
commit517343fddd94e620e94be97ae22eca4b57dc7625 (patch)
tree70b62f663c2d6f154c8808e55e827c69509918bd /dev-cpp/curlpp
parent6554f04b9a44e1ffe5d2f614201c11deed2703bd (diff)
gentoo auto-resync : 18:02:2023 - 02:09:39
Diffstat (limited to 'dev-cpp/curlpp')
-rw-r--r--dev-cpp/curlpp/Manifest4
-rw-r--r--dev-cpp/curlpp/curlpp-0.8.1.ebuild34
-rw-r--r--dev-cpp/curlpp/files/curlpp-0.8.1-fix-pkgconfig.patch39
-rw-r--r--dev-cpp/curlpp/metadata.xml24
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-cpp/curlpp/Manifest b/dev-cpp/curlpp/Manifest
new file mode 100644
index 000000000000..2f3ab8466c1f
--- /dev/null
+++ b/dev-cpp/curlpp/Manifest
@@ -0,0 +1,4 @@
+AUX curlpp-0.8.1-fix-pkgconfig.patch 1324 BLAKE2B b1b2e235b586cab2c08b35b52784e654cec32159b6ca37a53ac84ca36acad87c0f96cb403069d27c78d2fdb0fd70b02c70631e6dfdfcb5765372af4ca89c304e SHA512 04d7d9800f02b1364728d71c80ab6af1f16abf35224ff07623a925895360f06a8afad4795dba2e6a1403b860905c9114f114e53ecfca9b4186d8729248aa3c75
+DIST curlpp-0.8.1.tar.gz 143017 BLAKE2B 7f3911499b42077c9f108b0355005744300383836a1c82dcba80207482b231527482fb17dcd78a7f288903e996afaf49a4478c7cb5c821bf597b26f4450a430b SHA512 a46b47150c0f0f1f0056e08966ce2fefa5e86fc729406e0220fbcf400da5409f05c87b636b13da3c4d4460c1177aedb494b9569bbcd9012326d4d5f59376397e
+EBUILD curlpp-0.8.1.ebuild 665 BLAKE2B 16cb029ce28c6208ebde5ec479910d0caae13d35166c2767920f31dd56411addbfa23f885d510638b26aeac7a3bf46f14d9e81aa70a23b4394b8025840f21c16 SHA512 a79ab6ecab8cff7b6d699bdbde46154f35eca17432d113fc4edaa337c9aec4161cbf6c0b88fcfae3161d57136a975f2f295e8e43d090c13590a2909729f4ea0a
+MISC metadata.xml 796 BLAKE2B 85996bee4498e368b11f77eb33f2813d8650d9c193f32bc6e1021597a376eec9411ab1eb50c873071cc9b464e9abf4665f32a22e36eccb7f413d22b49a2907f3 SHA512 8a95aac399bcdc8a9e9af98a18b04790b72838bbbc957cd096e5d7220fc1772d5ba90a0dc1a4303b14159dab93376b3f8dd2ac62cbc3004d543d00477e943dca
diff --git a/dev-cpp/curlpp/curlpp-0.8.1.ebuild b/dev-cpp/curlpp/curlpp-0.8.1.ebuild
new file mode 100644
index 000000000000..8f19bb669879
--- /dev/null
+++ b/dev-cpp/curlpp/curlpp-0.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2018-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ wrapper for libcURL"
+HOMEPAGE="https://www.curlpp.org/"
+SRC_URI="https://github.com/jpbarrette/curlpp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="net-misc/curl"
+DEPEND="${RDEPEND}"
+
+DOCS=( Readme.md doc/AUTHORS doc/TODO )
+
+PATCHES=( "${FILESDIR}"/${P}-fix-pkgconfig.patch )
+
+src_install() {
+ use doc && DOCS+=( doc/guide.pdf )
+
+ cmake_src_install
+
+ rm "${ED}"/usr/$(get_libdir)/libcurlpp.a || die
+
+ if use examples ; then
+ dodoc -r examples/
+ fi
+}
diff --git a/dev-cpp/curlpp/files/curlpp-0.8.1-fix-pkgconfig.patch b/dev-cpp/curlpp/files/curlpp-0.8.1-fix-pkgconfig.patch
new file mode 100644
index 000000000000..701c81e9c43e
--- /dev/null
+++ b/dev-cpp/curlpp/files/curlpp-0.8.1-fix-pkgconfig.patch
@@ -0,0 +1,39 @@
+# upstream commit: <https://github.com/jpbarrette/curlpp/commit/5cdb4eb>
+
+From 5cdb4eb7ae898bc9b81cd1a7f87986827848456a Mon Sep 17 00:00:00 2001
+From: Dale Mellor <black-hole@rdmp.org>
+Date: Thu, 6 Jan 2022 18:57:23 +0000
+Subject: [PATCH] Put full paths in pkg-config specification.
+
+Currently, 'pkg-config --cflags curlpp' gives '-Iinclude', which is not good
+enough for outside projects to link to this package.
+
+* extras/curlpp.pc.in: use internal variables to make the generated
+ specifications more precise.
+---
+ extras/curlpp.pc.in | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/extras/curlpp.pc.in b/extras/curlpp.pc.in
+index b040ee0..e19c5b2 100644
+--- a/extras/curlpp.pc.in
++++ b/extras/curlpp.pc.in
+@@ -1,13 +1,13 @@
+ # This is a comment
+ prefix=@prefix@
+-exec_prefix=@prefix@
+-includedir=@includedir@
++exec_prefix=${prefix}
++includedir=${prefix}/@includedir@
++libdir=${exec_prefix}/@libdir@
+
+ Name: curlpp
+ Description: cURLpp is a libcurl C++ wrapper
+ Version: @VERSION@
+-Libs: -L@libdir@ -lcurlpp @LDFLAGS@ @LIBS@
+-Cflags: -I@includedir@ @CURLPP_CXXFLAGS@
++Libs: -L${libdir} -lcurlpp @LDFLAGS@ @LIBS@
++Cflags: -I${includedir} @CURLPP_CXXFLAGS@
+ # libcurl is required as non-private because CurlHandle.inl uses curl_easy_setopt.
+ Requires: libcurl
+-
diff --git a/dev-cpp/curlpp/metadata.xml b/dev-cpp/curlpp/metadata.xml
new file mode 100644
index 000000000000..045b624e941f
--- /dev/null
+++ b/dev-cpp/curlpp/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>gentoo@tastytea.de</email>
+ <name>tastytea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <name>Jean-Philippe Barrette-LaPierre</name>
+ </maintainer>
+ <doc>https://github.com/jpbarrette/curlpp/blob/master/doc/guide.pdf</doc>
+ <bugs-to>https://github.com/jpbarrette/curlpp/issues</bugs-to>
+ <remote-id type="github">jpbarrette/curlpp</remote-id>
+ </upstream>
+</pkgmetadata>