summaryrefslogtreecommitdiff
path: root/dev-cpp/ctemplate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /dev-cpp/ctemplate
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'dev-cpp/ctemplate')
-rw-r--r--dev-cpp/ctemplate/Manifest2
-rw-r--r--dev-cpp/ctemplate/ctemplate-2.4.ebuild13
2 files changed, 10 insertions, 5 deletions
diff --git a/dev-cpp/ctemplate/Manifest b/dev-cpp/ctemplate/Manifest
index 3c56ffb05648..590c780166e1 100644
--- a/dev-cpp/ctemplate/Manifest
+++ b/dev-cpp/ctemplate/Manifest
@@ -1,4 +1,4 @@
AUX 70ctemplate-gentoo.el 282 BLAKE2B 6004cc2b2e543f47c0c808bf494160c4b7e7e4768a954c1b0d99bc065a89145875dfc2b1e386bdf3a5e4dbb375a0bf5badc45b1666320f2a00fa8bd108f16c09 SHA512 36bc5424cb6dce40026f1d08b8764bf43d42159ff20e7d81484f5baf1c1e3c2042c12b1a60fc3cef48e297e816a12dbc41169988a6537ee41a2e2528b3c834a3
DIST ctemplate-2.4.tar.gz 391923 BLAKE2B 96b585ed6ca323fc461857e1f2f381e0ca5c229d8c6039c24efcf34fb9ddf45cc36bef141af337e591e1cdd95ca510ea5ba1e539554322c578c25187b1906195 SHA512 4955489e7327bce18802d50fd9dfc8ac12af685e556d1c9d0eb2b7a2f4a9b6086e30be8388d694ec8912623738973d0c76e9ca97196c63c139ee5b468d4858b7
-EBUILD ctemplate-2.4.ebuild 1521 BLAKE2B 30641f29e497249c68c92612b14ce681ae765c0de7db3022124bd9ea5b629a91f1319916026254c0146ac677ba5a9c069492f50f51a316838ae8e9b1408e40a8 SHA512 46262f7a5a85774f10ce16b9ad1afd1c2df500177a3dafbd6fb69e554f259fcb6f01dba849259bc2e24d82328d4f947592a74832ed3b179454835791d123c01b
+EBUILD ctemplate-2.4.ebuild 1651 BLAKE2B 6a44571e567c38aa553c0a02873a9bc0406486cad98f562bc1ec2f0cfc5b8a06bad0c193a4d31a8b2b6249afdc86ffab1a2be9bdced439eeba42e5c6a975bf22 SHA512 34351348512026c0ef0cbfaaffd0f7e21b454289fcaf9e68765221cc4d2bb31e917b31fd2c21d5f5aa8ba261d07054d77076317cbf4f6018fb59a169c700c485
MISC metadata.xml 314 BLAKE2B f6d4b334aa6c7bdc8e813da5170b39f55d111fc1112595fc5000f7b05866a518141d514e6496ad4bfef4c818646bfdccec88fe73a6caf1912c8cf65fb064b1ff SHA512 e9f7539c69d3a229e776513eddddc9a8b7151e4dea8d2782335f169d5a988c8f1e7e28fc3698832bc1fae58d47e5274d608e3ce5772a69bac1a2f4000c39e656
diff --git a/dev-cpp/ctemplate/ctemplate-2.4.ebuild b/dev-cpp/ctemplate/ctemplate-2.4.ebuild
index b1a2a9d2775c..8224d19db62c 100644
--- a/dev-cpp/ctemplate/ctemplate-2.4.ebuild
+++ b/dev-cpp/ctemplate/ctemplate-2.4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..13} )
-inherit autotools elisp-common python-any-r1
+inherit autotools elisp-common flag-o-matic python-any-r1
DESCRIPTION="A simple but powerful template language for C++"
HOMEPAGE="https://github.com/olafvdspek/ctemplate"
@@ -33,6 +33,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/924637
+ # https://github.com/OlafvdSpek/ctemplate/issues/157
+ filter-lto
+
econf $(use_enable static-libs static)
}