summaryrefslogtreecommitdiff
path: root/dev-cpp/ctemplate/ctemplate-2.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-cpp/ctemplate/ctemplate-2.3-r1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-cpp/ctemplate/ctemplate-2.3-r1.ebuild')
-rw-r--r--dev-cpp/ctemplate/ctemplate-2.3-r1.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/dev-cpp/ctemplate/ctemplate-2.3-r1.ebuild b/dev-cpp/ctemplate/ctemplate-2.3-r1.ebuild
deleted file mode 100644
index a578d0f6a249..000000000000
--- a/dev-cpp/ctemplate/ctemplate-2.3-r1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools elisp-common python-any-r1
-
-DESCRIPTION="A simple but powerful template language for C++"
-HOMEPAGE="https://github.com/olafvdspek/ctemplate"
-SRC_URI="https://dev.gentoo.org/~pinkbyte/distfiles/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm ppc x86 ~amd64-linux ~x86-linux"
-IUSE="doc emacs vim-syntax static-libs test"
-
-DEPEND="test? ( ${PYTHON_DEPS} )"
-RDEPEND="
- emacs? ( virtual/emacs )
- vim-syntax? ( >=app-editors/vim-core-7 )"
-
-SITEFILE="70ctemplate-gentoo.el"
-
-# Some tests are broken in 2.3
-RESTRICT="test"
-
-PATCHES=( "${FILESDIR}"/${PN}-2.3-fix-build-system.patch )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable static-libs static)
-}
-
-src_compile() {
- default
-
- if use emacs; then
- elisp-compile contrib/tpl-mode.el
- fi
-}
-
-src_install() {
- default
- if ! use doc; then
- rm -r "${ED%/}"/usr/share/doc/${PF}/html || die
- fi
-
- if use vim-syntax; then
- cd "${S}/contrib" || die
- sh highlighting.vim || die "unpacking vim scripts failed"
- insinto /usr/share/vim/vimfiles
- doins -r .vim/.
- fi
-
- if use emacs; then
- cd "${S}/contrib" || die
- elisp-install ${PN} tpl-mode.el tpl-mode.elc
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- # package provides .pc files
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}