summaryrefslogtreecommitdiff
path: root/dev-cpp/cpp-taskflow
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /dev-cpp/cpp-taskflow
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'dev-cpp/cpp-taskflow')
-rw-r--r--dev-cpp/cpp-taskflow/Manifest2
-rw-r--r--dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-cpp/cpp-taskflow/Manifest b/dev-cpp/cpp-taskflow/Manifest
index 0ed2db3f362a..29e1dc89930b 100644
--- a/dev-cpp/cpp-taskflow/Manifest
+++ b/dev-cpp/cpp-taskflow/Manifest
@@ -1,4 +1,6 @@
AUX cpp-taskflow-3.0.0-gnuinstalldir.patch 3340 BLAKE2B 2e36ea275ff93b12189e14d9a9e4a7141fb0b183ab68ce8fd76336feee34150a8f36d07bfd0eee41df04654968ae4c8de2e45df0d5de73e7e5b49f36de61a1b8 SHA512 f42539ec5612920112f7e56b7300cdee2efd8c6e93167d410b66bdacd6c827c09220162e6217fb22163ed152a364f68f16c9f255157436cc9086efcfb67ad722
DIST cpp-taskflow-3.0.0.tar.gz 79242171 BLAKE2B 18a89fbc2dc8d37ed03a3b1002b7803c37cfa9b6f3bd6a29e53756165971ec557e2ba60b72417f400f0b1c5fe12a0d8b88ada109abc539838b7d5eb1c10f6237 SHA512 5c838ff4436ade1f3755eb6859f724188be2bfcd11baf172413a0bdc18bc516b7b911e6d83a140c95548f844a8c8b908992bdec10b3b6569876a3e3b2d5b821e
+DIST cpp-taskflow-3.2.0.tar.gz 79152157 BLAKE2B 03b4b1cf772c9dec4557a706c7872de95312d4e72ec7dcef1accfd1d5eaf470e60440d75ea0c993ab494ef460dc44639719ea1732fa92c54d64dde31b90b9224 SHA512 e30d95b69f64524c9b06cf7442236998f91b1083818f06439888d78d5a1b988bc952c02fd0ec88114283cbe6c31a7bbfe810a7114998f4b5f60c4cff921bb0fa
EBUILD cpp-taskflow-3.0.0.ebuild 692 BLAKE2B 403c306382a21a930d1de638ae95fca69ea983a3a69eb530e35b0e89a4905b16cc2bd639df2bcfdbba6d04f855d2eb178faebbe2411ea443b66d2aa78ef7c68f SHA512 2ab540db996797b44c9fbf64a6a84f7cdf33b51243f822f4b4b0a42511ccb603fecaae63253b990701324e47824e572d1c448c22328653abf22afc59cc716d01
+EBUILD cpp-taskflow-3.2.0.ebuild 640 BLAKE2B d3b0cb72bb472fb33746ebaf30b754a8892ef1c0607009a5c0adc0a8700d1102a8597ad21950bb454d75c073c19f0e4906db89b2e82d3dde62096646c8a42ebd SHA512 12d15a698591a04705f905593e722030e61a932910e5f4833a653815894893eb239eb0ff46b15163138ea356396e035256fb448f8045ba53b6e7a4ae1d632a7e
MISC metadata.xml 663 BLAKE2B d9364c3cb5391e8b95488f7016d1dcf51400970c8ea0737549c91ca3ec4ac1132c3c34d76bc2aaefe80dbef2887ae28e150d8d396d297c19fc2d45b7f827417e SHA512 054c5840f22ed9ecb67c85a7ca78898ab7897de5bb254ab61a602ec1031e92cde398525c9c97c59d0b66a57f3fab5f8acb0efa511c958a6754dcf7f2c0c77359
diff --git a/dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild b/dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild
new file mode 100644
index 000000000000..fc6e30fbb60c
--- /dev/null
+++ b/dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Modern C++ Parallel Task Programming"
+HOMEPAGE="https://cpp-taskflow.github.io"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/taskflow-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+HTML_DOCS=( docs/. )
+
+src_configure() {
+ # TODO: enable CUDA via USE flag
+ local mycmakeargs=(
+ -DTF_BUILD_CUDA=OFF
+ -DTF_BUILD_EXAMPLES=$(usex examples)
+ -DTF_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}