summaryrefslogtreecommitdiff
path: root/dev-cpp/cpp-hocon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-cpp/cpp-hocon
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-cpp/cpp-hocon')
-rw-r--r--dev-cpp/cpp-hocon/Manifest3
-rw-r--r--dev-cpp/cpp-hocon/cpp-hocon-0.1.4.ebuild44
-rw-r--r--dev-cpp/cpp-hocon/metadata.xml14
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-cpp/cpp-hocon/Manifest b/dev-cpp/cpp-hocon/Manifest
new file mode 100644
index 000000000000..1302e76bedd0
--- /dev/null
+++ b/dev-cpp/cpp-hocon/Manifest
@@ -0,0 +1,3 @@
+DIST cpp-hocon-0.1.4.tar.gz 157988 BLAKE2B 3b9e3ec2c386446a2c1d078867b03fbfe2adc8160877288597c648eaf4af6e34f09b673780e6fb81ce9bd1724c1e3d6efc1102985d344a4d1d7bb48b15916190 SHA512 f5ee6c5e7eaa5139bb3c421fd8b7c0da337daec99dce7f426d567ced0036b7c49a396b1b9bdbaa8023cd776a5a942175082a4b30280d4211a0db51483324be42
+EBUILD cpp-hocon-0.1.4.ebuild 984 BLAKE2B c9d4cca295d73931c1a47fa9b90040dd54f012a16377384456c26eba97e70b04e828fdd7c70587d4335af789849633f87830a2e26e70bbb717ee7099b740129c SHA512 b6d3e6cdd42a210d5dc147722d71dc0431155d44558e369e34683a3afa9981a65caded4efe8282b0ec1fdc0ccca892688693c8f792069fc2a22a9e844b055323
+MISC metadata.xml 433 BLAKE2B 5b3b4e23af7ff914d5b4a3ba6425f469273ef8fb513766a07b3d66110688df34dfd68b43812905bea98cc39c2b3df06b5614bf504a78f4c2ce0c6d56bfe483a3 SHA512 7f890317b6cdfc71563359d575446ccf489d6ffb79ba541566fa747e4a0c1e077ec7f7c5263d96035bbfe77f6631cfb9000f715c348ed543492b7dc4cc7cd305
diff --git a/dev-cpp/cpp-hocon/cpp-hocon-0.1.4.ebuild b/dev-cpp/cpp-hocon/cpp-hocon-0.1.4.ebuild
new file mode 100644
index 000000000000..401c60179d01
--- /dev/null
+++ b/dev-cpp/cpp-hocon/cpp-hocon-0.1.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Provides C++ support for the HOCON configuration file format"
+HOMEPAGE="https://github.com/puppetlabs/cpp-hocon"
+SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ppc ppc64 sparc x86"
+IUSE="debug test"
+
+DEPEND="
+ >=sys-devel/gcc-4.9.3:*
+ >=dev-libs/boost-1.54[nls]
+ >=dev-libs/leatherman-0.9.3
+ "
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # make it support multilib
+ sed -i "s/\ lib)/\ $(get_libdir))/g" lib/CMakeLists.txt || die
+ sed -i "s/lib\")/$(get_libdir)\")/g" CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCMAKE_BUILD_TYPE=None
+ -DCMAKE_INSTALL_PREFIX=/usr
+ )
+ if use debug; then
+ mycmakeargs+=(
+ -DCMAKE_BUILD_TYPE=Debug
+ )
+ fi
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/cpp-hocon/metadata.xml b/dev-cpp/cpp-hocon/metadata.xml
new file mode 100644
index 000000000000..07ce8804cf91
--- /dev/null
+++ b/dev-cpp/cpp-hocon/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">puppetlabs/cpp-hocon</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ A C++ port of the Typesafe Config library.
+ </longdescription>
+</pkgmetadata>