summaryrefslogtreecommitdiff
path: root/dev-cpp/cctz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-03 01:32:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-03 01:32:36 +0000
commit92b7880bd28edc591d46c65b2242bbad6106fb39 (patch)
tree0b5c4ff09cb0e02c310fe6c37b2bf391cf932c80 /dev-cpp/cctz
parent7228e7507f59b8f0982c3a68cc5ba8ea35ce1a76 (diff)
gentoo auto-resync : 03:03:2023 - 01:32:36
Diffstat (limited to 'dev-cpp/cctz')
-rw-r--r--dev-cpp/cctz/Manifest3
-rw-r--r--dev-cpp/cctz/cctz-2.3_p20230228.ebuild32
-rw-r--r--dev-cpp/cctz/metadata.xml16
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-cpp/cctz/Manifest b/dev-cpp/cctz/Manifest
new file mode 100644
index 000000000000..edfde6a3e3fa
--- /dev/null
+++ b/dev-cpp/cctz/Manifest
@@ -0,0 +1,3 @@
+DIST cctz-2.3_p20230228.tar.gz 218332 BLAKE2B c29f2acf12d73387faf0087ef94b8624b5eefa2cf3136e0003e59a6a89b8a73f6de97f1962031ca1b1b1f4f6e888a363314aa1e160ad54c618189ad4a7d8f60e SHA512 ab6a103a6073a8169cd08587d2415dcab6c6e6c005b4b67fb69cc718b8b73a1331c5782b27aa4924aa5bdedc1563e31aa3ac76196078c50a13773d35d8df993b
+EBUILD cctz-2.3_p20230228.ebuild 660 BLAKE2B d18673cb0a17df2ea1c190dcfa582dcc897aca3905fc26fc78d978373fc9b04d78ff22f467b2506de1f4dc85663e72ca272dd4c9b4b16a9807077c84a9e4868c SHA512 eea3dcd221f1613180003b22d0b39ea1a7218e1365f35757de2a8c45c51ded5e033f56b37e0563efb261eab509f7de3ff0f934d2762a6e0e582024698f2f8af1
+MISC metadata.xml 512 BLAKE2B 77ff30bded40acd62952b195d6a079ca2e490aa17a02dd83e777a7e5fe87a70dfbac9da7107447bd0dcee19dc9ed7bca3169e165ab1ce7c18d45d2403b9dfd5d SHA512 1cfa31b17ac83e5e60494d85726e9a44d0d090d9d7e0ab351e7a939ff7db63b6ab960a1d18f4750b29933c5b079890be90aea3945be6b4b406fa7e27df2ca067
diff --git a/dev-cpp/cctz/cctz-2.3_p20230228.ebuild b/dev-cpp/cctz/cctz-2.3_p20230228.ebuild
new file mode 100644
index 000000000000..448b7f921122
--- /dev/null
+++ b/dev-cpp/cctz/cctz-2.3_p20230228.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ library for dealing with time zones and time conversion"
+HOMEPAGE="https://github.com/google/cctz"
+MY_COMMIT="3803b96130934f48b1fc1d47c5da5f542949c4b0"
+SRC_URI="https://github.com/google/cctz/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-cpp/gtest
+ )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ -DBUILD_BENCHMARK=OFF
+ )
+ cmake_src_configure
+}
diff --git a/dev-cpp/cctz/metadata.xml b/dev-cpp/cctz/metadata.xml
new file mode 100644
index 000000000000..aadf008c9297
--- /dev/null
+++ b/dev-cpp/cctz/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sbraz@gentoo.org</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>alexey+gentoo@asokolov.org</email>
+ <name>Alexey Sokolov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">google/cctz</remote-id>
+ <bugs-to>https://github.com/google/cctz/issues</bugs-to>
+ </upstream>
+</pkgmetadata>