summaryrefslogtreecommitdiff
path: root/dev-cpp/catch/catch-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-cpp/catch/catch-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-cpp/catch/catch-9999.ebuild')
-rw-r--r--dev-cpp/catch/catch-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/catch/catch-9999.ebuild b/dev-cpp/catch/catch-9999.ebuild
new file mode 100644
index 000000000000..5ca782d46a21
--- /dev/null
+++ b/dev-cpp/catch/catch-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/philsquared/Catch.git"
+EGIT_BRANCH=catch2
+inherit cmake-utils git-r3
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/philsquared/Catch"
+SRC_URI=""
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+# CMake is only used to build & run tests, so override phases
+src_configure() { :; }
+src_compile() { :; }
+
+src_test() {
+ cmake-utils_src_configure
+ cmake-utils_src_compile
+ cmake-utils_src_test
+}
+
+src_install() {
+ # same location as used in fedora
+ insinto /usr/include/catch
+ doins -r include/.
+ dodoc -r docs/.
+}