summaryrefslogtreecommitdiff
path: root/dev-cpp/catch/catch-3.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-12 00:09:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-12 00:09:22 +0000
commit8fa69fdd0836c0b856dd0f9ef77d5fb25df844ec (patch)
tree5b2388d462e1ce30c6c01d22c809fab8b5beee8f /dev-cpp/catch/catch-3.3.2.ebuild
parent23650861e24563ddcf10919ab5b1912676c3ff0c (diff)
gentoo auto-resync : 12:03:2023 - 00:09:21
Diffstat (limited to 'dev-cpp/catch/catch-3.3.2.ebuild')
-rw-r--r--dev-cpp/catch/catch-3.3.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-cpp/catch/catch-3.3.2.ebuild b/dev-cpp/catch/catch-3.3.2.ebuild
new file mode 100644
index 000000000000..410551334707
--- /dev/null
+++ b/dev-cpp/catch/catch-3.3.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit cmake python-any-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/catchorg/Catch2.git"
+else
+ MY_P=${PN^}2-${PV}
+ SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/catchorg/Catch2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCATCH_DEVELOPMENT_BUILD=ON
+ -DCATCH_ENABLE_WERROR=OFF
+ -DCATCH_BUILD_TESTING=$(usex test)
+ )
+ use test && mycmakeargs+=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+
+ cmake_src_configure
+}