summaryrefslogtreecommitdiff
path: root/dev-cpp/catch/catch-2.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-27 18:07:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-27 18:07:28 +0000
commit67f76a858f1ac826bd8a550d756d9ec6e340ed4f (patch)
tree45f4ada6be05bc180a14e017c9d5c6b58a0eec6e /dev-cpp/catch/catch-2.1.1.ebuild
parent38b7258d086dd5e263c3bbe3880c8c956676bc71 (diff)
gentoo resync : 27.01.2018
Diffstat (limited to 'dev-cpp/catch/catch-2.1.1.ebuild')
-rw-r--r--dev-cpp/catch/catch-2.1.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-cpp/catch/catch-2.1.1.ebuild b/dev-cpp/catch/catch-2.1.1.ebuild
new file mode 100644
index 000000000000..d7763c4ccaa9
--- /dev/null
+++ b/dev-cpp/catch/catch-2.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+inherit cmake-utils
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/catchorg/Catch2.git"
+else
+ MY_P=${PN^}2-${PV}
+ SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+
+ S=${WORKDIR}/${MY_P}
+fi
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/catchorg/Catch2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCATCH_ENABLE_WERROR=OFF
+ -DBUILD_TESTING=$(usex test)
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
+ )
+ cmake-utils_src_configure
+}