summaryrefslogtreecommitdiff
path: root/dev-cpp/atkmm/atkmm-2.36.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-cpp/atkmm/atkmm-2.36.1.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-cpp/atkmm/atkmm-2.36.1.ebuild')
-rw-r--r--dev-cpp/atkmm/atkmm-2.36.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-cpp/atkmm/atkmm-2.36.1.ebuild b/dev-cpp/atkmm/atkmm-2.36.1.ebuild
new file mode 100644
index 000000000000..0ab832b961c8
--- /dev/null
+++ b/dev-cpp/atkmm/atkmm-2.36.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit gnome.org meson multilib-minimal python-any-r1
+
+DESCRIPTION="C++ interface for the ATK library"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.36"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="doc"
+
+DEPEND="
+ >=dev-cpp/glibmm-2.68.0:2.68[doc?,${MULTILIB_USEDEP}]
+ >=dev-libs/atk-2.18.0[${MULTILIB_USEDEP}]
+ dev-libs/libsigc++:3[doc?,${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ dev-lang/perl
+ dev-libs/libxslt
+ )
+ ${PYTHON_DEPS}
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dbuild-documentation=$(multilib_native_usex doc true false)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_test() {
+ meson_src_test
+}