summaryrefslogtreecommitdiff
path: root/dev-cpp/argparse/argparse-3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-05 00:07:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-05 00:07:53 +0100
commit9d1e33edaf09cde926d589461f40e378d4124be9 (patch)
treeb0a5a85acd92ce912a95245121dde9cebcf76b71 /dev-cpp/argparse/argparse-3.0.ebuild
parentdafa6f367240d1f5329ca89fb6f78985dbdc025b (diff)
gentoo auto-resync : 05:06:2024 - 00:07:52
Diffstat (limited to 'dev-cpp/argparse/argparse-3.0.ebuild')
-rw-r--r--dev-cpp/argparse/argparse-3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-cpp/argparse/argparse-3.0.ebuild b/dev-cpp/argparse/argparse-3.0.ebuild
new file mode 100644
index 000000000000..478612f014e0
--- /dev/null
+++ b/dev-cpp/argparse/argparse-3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Argument Parser for Modern C++"
+HOMEPAGE="https://github.com/p-ranav/argparse"
+SRC_URI="https://github.com/p-ranav/argparse/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DARGPARSE_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}"/test || die
+ ./tests || die
+}