summaryrefslogtreecommitdiff
path: root/dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild')
-rw-r--r--dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild b/dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild
new file mode 100644
index 000000000000..93dee6e7c913
--- /dev/null
+++ b/dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="The ANTLR 4 C++ Runtime"
+HOMEPAGE="https://www.antlr.org/"
+SRC_URI="https://www.antlr.org/download/antlr4-cpp-runtime-${PV}-source.zip -> ${P}.zip"
+LICENSE="BSD"
+SLOT="4"
+KEYWORDS="amd64 x86"
+
+DEPEND="app-arch/zip"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ sed -i -e "s#DESTINATION lib#DESTINATION $(get_libdir)#" \
+ "${S}"/runtime/CMakeLists.txt || die "failed sed"
+
+ sed -i -e "s#share/doc/libantlr4#share/doc/${P}#g" \
+ "${S}"/CMakeLists.txt || die "failed sed"
+
+ cmake-utils_src_prepare
+}