summaryrefslogtreecommitdiff
path: root/dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild')
-rw-r--r--dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild b/dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild
index 9f123f017901..674acf4c9f29 100644
--- a/dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild
+++ b/dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild
@@ -8,19 +8,19 @@ inherit cmake
DESCRIPTION="The ANTLR 4 C++ Runtime"
HOMEPAGE="https://www.antlr.org/"
SRC_URI="https://www.antlr.org/download/antlr4-cpp-runtime-${PV}-source.zip -> ${P}.zip"
+S="${WORKDIR}"
+
LICENSE="BSD"
SLOT="4"
KEYWORDS="amd64 ~arm ~ppc x86"
-DEPEND="app-arch/unzip"
-
-S="${WORKDIR}"
+BDEPEND="app-arch/unzip"
src_prepare() {
sed -i -e "s#DESTINATION lib#DESTINATION $(get_libdir)#" \
"${S}"/runtime/CMakeLists.txt || die "failed sed"
- sed -i -e "s#share/doc/libantlr4#share/doc/${P}#g" \
+ sed -i -e "s#share/doc/libantlr4#share/doc/${PF}#g" \
"${S}"/CMakeLists.txt || die "failed sed"
cmake_src_prepare