summaryrefslogtreecommitdiff
path: root/dev-cpp/aixlog
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /dev-cpp/aixlog
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'dev-cpp/aixlog')
-rw-r--r--dev-cpp/aixlog/Manifest4
-rw-r--r--dev-cpp/aixlog/aixlog-1.2.1.ebuild29
-rw-r--r--dev-cpp/aixlog/aixlog-9999.ebuild29
-rw-r--r--dev-cpp/aixlog/metadata.xml20
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-cpp/aixlog/Manifest b/dev-cpp/aixlog/Manifest
new file mode 100644
index 000000000000..9263383f4bf2
--- /dev/null
+++ b/dev-cpp/aixlog/Manifest
@@ -0,0 +1,4 @@
+DIST aixlog-1.2.1.tar.gz 11396 BLAKE2B 88cdc775acfd91ee74306fedd6429865f10bcd7cbe9b45f861463489330d74b017611078ca362a00994983dde746ba086a056c3da53b06099f200810d65c0c04 SHA512 776558fdd911f0cc9e8d467bf8e00a1930d2e51bb8ccd5f36f95955fefecab65faf575a80fdaacfe83fd32808f8b9c2e0323b16823e0431300df7bc0c1dfde12
+EBUILD aixlog-1.2.1.ebuild 592 BLAKE2B b9ca8cc5003a0979db8cd2992f7ee4a28782c166a4d387b4fa97252f4a52a522f0221ad13a6b2422660cfe1ca61dae975d050769f989d974c445ac976f9b5466 SHA512 6fca9db55df82d0ec0fa7e0d352d0c4ec09925373e2e07a498261b63bffe9ed7bea8afa7ea24163e29827b557cd30006d92fdf9bd8b3ebd6d369fa4d01210640
+EBUILD aixlog-9999.ebuild 592 BLAKE2B b9ca8cc5003a0979db8cd2992f7ee4a28782c166a4d387b4fa97252f4a52a522f0221ad13a6b2422660cfe1ca61dae975d050769f989d974c445ac976f9b5466 SHA512 6fca9db55df82d0ec0fa7e0d352d0c4ec09925373e2e07a498261b63bffe9ed7bea8afa7ea24163e29827b557cd30006d92fdf9bd8b3ebd6d369fa4d01210640
+MISC metadata.xml 620 BLAKE2B b484dc5a04a850df14940bed20bc6479347e16114268f6bb1d5035395d7456dce6108b5a7a84dcdadd2444df2819e0bdbc5c004814d29aef6229d01df13f857f SHA512 66120820a33f2d18734e9ba8256e259559cc2daa236b83f825c6ee2b1d8cf25aa53aebaf2e523b534ac9a0abd64d42227d78ce11cd2b7fdde7830ead1aac652f
diff --git a/dev-cpp/aixlog/aixlog-1.2.1.ebuild b/dev-cpp/aixlog/aixlog-1.2.1.ebuild
new file mode 100644
index 000000000000..1246304bfa01
--- /dev/null
+++ b/dev-cpp/aixlog/aixlog-1.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Header-only C++ logging library"
+HOMEPAGE="https://github.com/badaix/aixlog"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit cmake-utils git-r3
+
+ EGIT_REPO_URI="https://github.com/badaix/aixlog.git"
+ EGIT_BRANCH="develop"
+else
+ inherit cmake-utils
+
+ SRC_URI="https://github.com/badaix/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_EXAMPLE=OFF )
+
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/aixlog/aixlog-9999.ebuild b/dev-cpp/aixlog/aixlog-9999.ebuild
new file mode 100644
index 000000000000..1246304bfa01
--- /dev/null
+++ b/dev-cpp/aixlog/aixlog-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Header-only C++ logging library"
+HOMEPAGE="https://github.com/badaix/aixlog"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit cmake-utils git-r3
+
+ EGIT_REPO_URI="https://github.com/badaix/aixlog.git"
+ EGIT_BRANCH="develop"
+else
+ inherit cmake-utils
+
+ SRC_URI="https://github.com/badaix/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_EXAMPLE=OFF )
+
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/aixlog/metadata.xml b/dev-cpp/aixlog/metadata.xml
new file mode 100644
index 000000000000..c2a58d893f1b
--- /dev/null
+++ b/dev-cpp/aixlog/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cb-gentoo@guya.de</email>
+ <name>Christian Buchinger</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <name>Johannes Pohl</name>
+ <email>github@badaix.de</email>
+ </maintainer>
+ <bugs-to>https://github.com/badaix/aixlog/issues</bugs-to>
+ <remote-id type="github">badaix/aixlog</remote-id>
+ </upstream>
+</pkgmetadata>