summaryrefslogtreecommitdiff
path: root/dev-build/tinycmmc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-15 01:16:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-15 01:16:32 +0000
commit7387c23ff485f2416512185bf64584028335b993 (patch)
tree77f6578297f64937d732133db350b968dfe538e3 /dev-build/tinycmmc
parentd8a50857c27d3253561374390ac9ed8c1b65d9bc (diff)
gentoo auto-resync : 15:01:2024 - 01:16:32
Diffstat (limited to 'dev-build/tinycmmc')
-rw-r--r--dev-build/tinycmmc/Manifest4
-rw-r--r--dev-build/tinycmmc/metadata.xml15
-rw-r--r--dev-build/tinycmmc/tinycmmc-0.1.0.ebuild20
-rw-r--r--dev-build/tinycmmc/tinycmmc-9999.ebuild20
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-build/tinycmmc/Manifest b/dev-build/tinycmmc/Manifest
new file mode 100644
index 000000000000..ebce358d2059
--- /dev/null
+++ b/dev-build/tinycmmc/Manifest
@@ -0,0 +1,4 @@
+DIST tinycmmc-0.1.0.tar.gz 10559 BLAKE2B 9708c6c95c5746d000bb02b46bc40b788b8b18d55d3bd2e97e88789f4b084e145db39e038b4d619c75273b8fd23713f6906a8618fa248664a468c60e1073000c SHA512 cf1e8108be2f5c8a23e08756b6f50a2493a688ffa8bd7a06a59330cdd74046035705f18d5f53a00d6779dafb76a2c529b4ca9be7e53ff2660d718e8f68544769
+EBUILD tinycmmc-0.1.0.ebuild 445 BLAKE2B 66e3fe94f318859605f60148d6f8c144739feb143a4e0792ff5672e3334ec0cdb613f8db3d93adbb5f6138bb55eafb78193cb9efed7d395cf9715aeb31555d2c SHA512 4a75dc331fea903dd2669f8d3f49c30d0b37df5ebd230a2f9a0bdf7d6cdac35cb693a63d78e895f8e9039290f04bddb6e20fc813e513c42af350d77263a127e5
+EBUILD tinycmmc-9999.ebuild 443 BLAKE2B ef06d90a1b0d731ef3b1ff7bfca5cc53b57d68c99e4bc17965a2392ee3190f30143d93b138e41f8c1a4d823695f37d0989dcecf0d3ebfa42c1e828e1624a1c20 SHA512 32be3f979a3d7ca5fc9a4b04a51305923e579566e533149efa340547243b9a8dddb3f1d5c8d6d273359cc225c4f1ce99dfc0b7a7b5cfae5542b928dc9e550cc7
+MISC metadata.xml 466 BLAKE2B 2fe1efd4c596f9c0023f6f6758da754cda0467f615798ff4f9eda4c9a4500db4364415ce14277dfbe40fdf1babde0a8ebd1ba636b58cb2776fc63ed977498304 SHA512 c0bf3b4a08ef90c34d7dfa222b59fb38cc6590465b9b2a93d5cbc501794f6ed36fc76ce971da04f495262964f4f7e8e659770881f7cb8308617ed60655b515c6
diff --git a/dev-build/tinycmmc/metadata.xml b/dev-build/tinycmmc/metadata.xml
new file mode 100644
index 000000000000..a85353b5969e
--- /dev/null
+++ b/dev-build/tinycmmc/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Grumbel/tinycmmc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-build/tinycmmc/tinycmmc-0.1.0.ebuild b/dev-build/tinycmmc/tinycmmc-0.1.0.ebuild
new file mode 100644
index 000000000000..88aaf86e9ab9
--- /dev/null
+++ b/dev-build/tinycmmc/tinycmmc-0.1.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Grumbel/${PN}.git"
+else
+ SRC_URI="https://github.com/Grumbel/${PN}/archive/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Tiny CMake Module Collections"
+HOMEPAGE="https://github.com/Grumbel/tinycmmc"
+
+LICENSE="GPL-3+"
+SLOT="0"
diff --git a/dev-build/tinycmmc/tinycmmc-9999.ebuild b/dev-build/tinycmmc/tinycmmc-9999.ebuild
new file mode 100644
index 000000000000..8bbe616423ad
--- /dev/null
+++ b/dev-build/tinycmmc/tinycmmc-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Grumbel/${PN}.git"
+else
+ SRC_URI="https://github.com/Grumbel/${PN}/archive/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Tiny CMake Module Collections"
+HOMEPAGE="https://github.com/Grumbel/tinycmmc"
+
+LICENSE="ZLIB"
+SLOT="0"