summaryrefslogtreecommitdiff
path: root/dev-build/rocm-cmake/files/rocm-cmake-6.1.1-no-rocmchecks-warnings.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-27 07:59:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-27 07:59:40 +0100
commitd2ed973482fdd800013658e83a61709b29e0a80f (patch)
tree57ea7666a57b5a05a4c8866e4915e90b4a6e7c94 /dev-build/rocm-cmake/files/rocm-cmake-6.1.1-no-rocmchecks-warnings.patch
parent9f6a82a85d400d6ae7de04c43cee88dbc6bc4da0 (diff)
gentoo auto-resync : 27:06:2024 - 07:59:39
Diffstat (limited to 'dev-build/rocm-cmake/files/rocm-cmake-6.1.1-no-rocmchecks-warnings.patch')
-rw-r--r--dev-build/rocm-cmake/files/rocm-cmake-6.1.1-no-rocmchecks-warnings.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-build/rocm-cmake/files/rocm-cmake-6.1.1-no-rocmchecks-warnings.patch b/dev-build/rocm-cmake/files/rocm-cmake-6.1.1-no-rocmchecks-warnings.patch
new file mode 100644
index 000000000000..73030e7b9b20
--- /dev/null
+++ b/dev-build/rocm-cmake/files/rocm-cmake-6.1.1-no-rocmchecks-warnings.patch
@@ -0,0 +1,25 @@
+Gentoo uses cmake -C <...>/gentoo_common_config.cmake approach to set toolchain variables.
+There is nothing wrong there, so there is no need to print huge ROCMChecks warnings.
+--- a/share/rocmcmakebuildtools/cmake/ROCMChecks.cmake
++++ b/share/rocmcmakebuildtools/cmake/ROCMChecks.cmake
+@@ -34,20 +34,6 @@ function(rocm_check_toolchain_var var access value list_file)
+ elseif("${base}" MATCHES ".*/CMakeFiles/${CMAKE_VERSION}$")
+ set(cmake_module On)
+ endif()
+- if(NOT cmake_module)
+- message( "
+-*******************************************************************************
+-*------------------------------- ${message_title} --------------------------*
+- Options and properties should be set on a cmake target where possible. The
+- variable '${var}' may be set by the cmake toolchain, either by
+- calling 'cmake -D${var}=\"${value}\"'
+- or set in a toolchain file and added with
+- 'cmake -DCMAKE_TOOLCHAIN_FILE=<toolchain-file>'. ROCMChecks now calling:")
+- message(${message_type} "'${var}' is set at ${CMAKE_CURRENT_LIST_DIR}/CMakeLists.txt:<line#> shown below:")
+- message( "*-----------------------------------------------------------------------------*
+-*******************************************************************************
+-")
+- endif()
+ endif()
+ endfunction()
+ if(UNIX AND (ROCM_WARN_TOOLCHAIN_VAR OR ROCM_ERROR_TOOLCHAIN_VAR))