summaryrefslogtreecommitdiff
path: root/dev-build/parmasan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-22 00:16:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-22 00:16:23 +0000
commit4c5bd80830992553e02f099442277e10ee97372d (patch)
treebeeb8ff1f9d6f5b48418cc2134cec247aaade4e4 /dev-build/parmasan
parentdb653baf275126269bb89ea0d2bdb8e50497a94c (diff)
gentoo auto-resync : 22:02:2025 - 00:16:22
Diffstat (limited to 'dev-build/parmasan')
-rw-r--r--dev-build/parmasan/Manifest3
-rw-r--r--dev-build/parmasan/metadata.xml11
-rw-r--r--dev-build/parmasan/parmasan-0_pre20250221-r1.ebuild26
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-build/parmasan/Manifest b/dev-build/parmasan/Manifest
new file mode 100644
index 000000000000..e90ed1a577fe
--- /dev/null
+++ b/dev-build/parmasan/Manifest
@@ -0,0 +1,3 @@
+DIST parmasan-0_pre20250221.gh.tar.gz 48700 BLAKE2B b77b724226fd05739177c5171dadc1d5c7cc3549daf5256cf6bdd50755399b4bbbdb1a9ffe92d480353abd8542e93bf1240faa412d537a10cf2e39944fb4f7a0 SHA512 7cbe3619d990fdb5da2980b13aeb6a63d0cc66028f093e2770884bca992c8db250b961e5f1bac59dc799426d72c4d591a918228c9f8005c8308dff2f9a8238d6
+EBUILD parmasan-0_pre20250221-r1.ebuild 658 BLAKE2B 7fa4c11fcef9fb794521fd11b5b0cd2704cc12b4427494fe4e1bcc3120976a7e6f1c74130de35db374a64efb7c8b4cb47acc9ef5ca6a59fa52f4b8aca27ea749 SHA512 1a80d5c35da7099bec3a8d12bc5443bc9d6a75001b215877fdc980385a2aba5e1d1c3f73c61c21a485386f1c4adaf523cd140d24d60f1267cfd74ea66ba64a5d
+MISC metadata.xml 320 BLAKE2B 08033380f604b736f81a99b5cc26c238b396c24cf18cb1162e1ce40857c2a92eed7131b621851abb3cf696376ef12147c5886eb35c341be2b7a8efc30f615367 SHA512 e0039369a4786cb07500238c85c4ac6c7da78b5e9855caf698742e222a8ec40dc3420e706aa0fba0f12d721146a07a6414460620fd9d9456eae8b265339b1d10
diff --git a/dev-build/parmasan/metadata.xml b/dev-build/parmasan/metadata.xml
new file mode 100644
index 000000000000..216ef4cb9302
--- /dev/null
+++ b/dev-build/parmasan/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ispras/parmasan</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-build/parmasan/parmasan-0_pre20250221-r1.ebuild b/dev-build/parmasan/parmasan-0_pre20250221-r1.ebuild
new file mode 100644
index 000000000000..bbbaec0af94e
--- /dev/null
+++ b/dev-build/parmasan/parmasan-0_pre20250221-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+PARMASAN_COMMIT="a313a554e2e288764b6f83761416c90990a00cee"
+DESCRIPTION="Parallel make sanitizer"
+HOMEPAGE="https://github.com/ispras/parmasan"
+SRC_URI="https://github.com/ispras/parmasan/archive/${PARMASAN_COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}"/${PN}-${PARMASAN_COMMIT}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-build/parmasan-remake"
+
+src_install() {
+ cmake_src_install
+
+ # Let's make it less likely to collide and it's then common
+ # with parmasan-remake.
+ mv "${ED}"/usr/bin/{,parmasan-}tracer || die
+}