summaryrefslogtreecommitdiff
path: root/dev-build/parmasan-remake
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-22 00:16:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-22 00:16:23 +0000
commit4c5bd80830992553e02f099442277e10ee97372d (patch)
treebeeb8ff1f9d6f5b48418cc2134cec247aaade4e4 /dev-build/parmasan-remake
parentdb653baf275126269bb89ea0d2bdb8e50497a94c (diff)
gentoo auto-resync : 22:02:2025 - 00:16:22
Diffstat (limited to 'dev-build/parmasan-remake')
-rw-r--r--dev-build/parmasan-remake/Manifest3
-rw-r--r--dev-build/parmasan-remake/metadata.xml11
-rw-r--r--dev-build/parmasan-remake/parmasan-remake-4.3_p20240220.ebuild65
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-build/parmasan-remake/Manifest b/dev-build/parmasan-remake/Manifest
new file mode 100644
index 000000000000..ccfc88d254d1
--- /dev/null
+++ b/dev-build/parmasan-remake/Manifest
@@ -0,0 +1,3 @@
+DIST parmasan-remake-4.3_p20240220.gh.tar.gz 1587763 BLAKE2B 901f0ca125b4f4dbfa71a175dfc42a0d4d239530563e3cbf971c7156aa51382f0e0ca5e5117c18b082f142842be16fce70b24a889c5f5ecf28e7541c06a467b9 SHA512 50deea4d526abb3de20009a54593f71995caa16e270a6b6343a965d91f285be6b6ba1a7f8ebea0c856fcee8785747a5ee7a9e4a166fe64bc99bec989a187f095
+EBUILD parmasan-remake-4.3_p20240220.ebuild 1639 BLAKE2B 8e57c3953c9ffed9ef397e2453aa6960d478f14f2390b3aace6ce7c4bfa0a2ee72d88fdde5c68788c9858c9b73025531236d31b6fdcef80c76777522915a0834 SHA512 a6cff7c9b08d94042a7cdfa9d0c367f6f1602b774c2e765dc8acac81a8949ee50761a22915a473a9f6273d902ad7f105073c434fd842bd486cb9886429238d91
+MISC metadata.xml 327 BLAKE2B 319a96f112d9ae5309eedd47e035fc9370fa7bfeda9e6f237366b59531d7d73c5a56fa307f4accaebd2ba67e9250aaa553cd2e3f493a1cd3172dd3d4f05d3ec1 SHA512 8cf9a63f886aa472e6f99b74313e09f8b5d8cbb7742ca53ff4e06f5971ae41a0891213cc4c9d25f50591f3a87bd1be36aa7bf2b45fd874405cce1f17b4c305b9
diff --git a/dev-build/parmasan-remake/metadata.xml b/dev-build/parmasan-remake/metadata.xml
new file mode 100644
index 000000000000..a39c8f8b5258
--- /dev/null
+++ b/dev-build/parmasan-remake/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ispras/parmasan-remake</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-build/parmasan-remake/parmasan-remake-4.3_p20240220.ebuild b/dev-build/parmasan-remake/parmasan-remake-4.3_p20240220.ebuild
new file mode 100644
index 000000000000..0c8a73122f11
--- /dev/null
+++ b/dev-build/parmasan-remake/parmasan-remake-4.3_p20240220.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+REMAKE_COMMIT="ff799578de24cf4be6ec230702ff5f978432ca51"
+DESCRIPTION="Patched dev-build/remake for dev-build/parmasan, a parallel make sanitizer"
+HOMEPAGE="https://github.com/ispras/parmasan-remake"
+SRC_URI="https://github.com/ispras/parmasan-remake/archive/${REMAKE_COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}"/${PN}-${REMAKE_COMMIT}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="readline"
+
+# Test failures caused by '--parmasan-strategy' appearing which is the point
+# of the project. The tests could possibly be adapted but aren't right now.
+RESTRICT="test"
+
+RDEPEND="
+ readline? ( sys-libs/readline:= )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # Fixed in upstream gnulib but not yet propagated into make (bug #938934)
+ append-cflags -std=gnu17
+ # Fixed in upstream make/gnulib, just not yet propagated into remake (bug #863827)
+ filter-lto
+
+ use readline || export vl_cv_lib_readline=no
+
+ local myeconfargs=(
+ --without-guile
+ --disable-nls
+
+ --with-make-name=${PN}
+ # parmasan doesn't support it, turn it off
+ # https://github.com/ispras/parmasan?tab=readme-ov-file#building
+ --disable-posix-spawn
+
+ # Fails to install w/ 'make.texi:5: @include: could not find version.texi'
+ MAKEINFO=:
+ )
+
+ econf "${myeconfargs[@]}"
+
+}
+
+src_install() {
+ default
+
+ # Avoid collision with dev-build/remake, not that parmasan seems
+ # to need this file anyway.
+ mv "${ED}"/usr/include/gnuremake.h "${ED}"/usr/include/gnuparmasan-remake.h || die
+}