summaryrefslogtreecommitdiff
path: root/dev-build/ignition-cmake
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-15 01:16:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-15 01:16:32 +0000
commit7387c23ff485f2416512185bf64584028335b993 (patch)
tree77f6578297f64937d732133db350b968dfe538e3 /dev-build/ignition-cmake
parentd8a50857c27d3253561374390ac9ed8c1b65d9bc (diff)
gentoo auto-resync : 15:01:2024 - 01:16:32
Diffstat (limited to 'dev-build/ignition-cmake')
-rw-r--r--dev-build/ignition-cmake/Manifest4
-rw-r--r--dev-build/ignition-cmake/files/protobuf.patch54
-rw-r--r--dev-build/ignition-cmake/ignition-cmake-2.17.0.ebuild24
-rw-r--r--dev-build/ignition-cmake/metadata.xml12
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-build/ignition-cmake/Manifest b/dev-build/ignition-cmake/Manifest
new file mode 100644
index 000000000000..968c04d7bb9a
--- /dev/null
+++ b/dev-build/ignition-cmake/Manifest
@@ -0,0 +1,4 @@
+AUX protobuf.patch 2224 BLAKE2B d9707647c874ea0b06232283c491c303317e27d8566b093752bfca5bcf6f919fc4d773e0c939e47e4e6fb39a026b07f569f03a1b9383c0a3ba9838d640082424 SHA512 1ce7f696424d8a8b1ae90372996dfd767ca2eb7f6e20f6e67daf6e16713013e0789b545584860203306d2d40830b2415844a939cf94dc08a5966489504e543dc
+DIST ignition-cmake2-2.17.0.tar.bz2 212353 BLAKE2B 4945559d35cea859383fc510fd2b78cbbd3127ef58c94fa239ecad3643725b7e003a9a18ddb25deec42938196adaf0a4f3466b602cf35dd1fe58f02c5a0ede91 SHA512 bb7263531c772474780fab990dafaa9697b1ce7d9113053bc7af3b2ae6cf292a46c6b37452e5bf720ef34ed3a9732503106d5e55b5ae813bed65618ae4ee69dc
+EBUILD ignition-cmake-2.17.0.ebuild 571 BLAKE2B 35347bacfb92adf249e71802e31ace9536a3934d07eddf463fc578e5c4e8d751666d22bea908af2b7e5822e9236f1a0efefa2dc99f70506a54a4c75feb3c8ba1 SHA512 3d4f6613c435f66943c67798f9ae152a191d4ecdadb61659050499836976f695eb06d7119ec9966841542cbf885e588c2ca6a217f4b5d371ff2a3b6818d093fd
+MISC metadata.xml 410 BLAKE2B f0398d55e4e2dc9cb7a350e9c2472d9a6b3856f9086b8dc4137d44c4b25c50cef6e9564cf44b1e7374fbfac72fc3990364e7c35962016644818069e6311adb1a SHA512 577eae419cf6950a1ae2b892a20c18428b490d6375ef05aad34bf0ac9a0acb246b26863e1175c5309d2900d5eb21aa603c32e27a16aa4c1dbd60006ceed5a2da
diff --git a/dev-build/ignition-cmake/files/protobuf.patch b/dev-build/ignition-cmake/files/protobuf.patch
new file mode 100644
index 000000000000..1bb2fe6480bb
--- /dev/null
+++ b/dev-build/ignition-cmake/files/protobuf.patch
@@ -0,0 +1,54 @@
+Index: ignition-cmake-2.17.0/cmake/FindIgnProtobuf.cmake
+===================================================================
+--- ignition-cmake-2.17.0.orig/cmake/FindIgnProtobuf.cmake
++++ ignition-cmake-2.17.0/cmake/FindIgnProtobuf.cmake
+@@ -26,12 +26,12 @@
+ include(IgnPkgConfig)
+ ign_pkg_config_entry(IgnProtobuf "protobuf >= ${IgnProtobuf_FIND_VERSION}")
+
+-find_package(Protobuf ${IgnProtobuf_FIND_VERSION} QUIET CONFIG)
++find_package(protobuf ${IgnProtobuf_FIND_VERSION} QUIET CONFIG)
+
+-if(NOT ${Protobuf_FOUND})
++if(NOT ${protobuf_FOUND})
+ # If a config-file was not found, then fall back on the system-installed
+ # find-module that comes with CMake.
+- find_package(Protobuf ${IgnProtobuf_FIND_VERSION})
++ find_package(protobuf ${IgnProtobuf_FIND_VERSION})
+ endif()
+
+ set(IgnProtobuf_missing_components "")
+@@ -49,21 +49,21 @@ foreach(component ${IgnProtobuf_FIND_COM
+
+ if((${component} STREQUAL "libprotobuf") OR (${component} STREQUAL "all"))
+ if((NOT PROTOBUF_LIBRARY) AND (NOT TARGET protobuf::libprotobuf))
+- set(Protobuf_FOUND false)
++ set(protobuf_FOUND false)
+ ign_string_append(IgnProtobuf_missing_components "libprotobuf" DELIM " ")
+ endif()
+ endif()
+
+ if((${component} STREQUAL "libprotoc") OR (${component} STREQUAL "all"))
+ if((NOT PROTOBUF_PROTOC_LIBRARY) AND (NOT TARGET protobuf::libprotoc))
+- set(Protobuf_FOUND false)
++ set(protobuf_FOUND false)
+ ign_string_append(IgnProtobuf_missing_components "libprotoc" DELIM " ")
+ endif()
+ endif()
+
+ if((${component} STREQUAL "protoc") OR (${component} STREQUAL "all"))
+ if((NOT PROTOBUF_PROTOC_EXECUTABLE) AND (NOT TARGET protobuf::protoc))
+- set(Protobuf_FOUND false)
++ set(protobuf_FOUND false)
+ ign_string_append(IgnProtobuf_missing_components "protoc" DELIM " ")
+ endif()
+ endif()
+@@ -74,7 +74,7 @@ if(IgnProtobuf_missing_components AND NO
+ message(STATUS "Missing required protobuf components: ${IgnProtobuf_missing_components}")
+ endif()
+
+-if(${Protobuf_FOUND})
++if(${protobuf_FOUND})
+ # If we have found Protobuf, then set the IgnProtobuf_FOUND flag to true so
+ # that ign_find_package(~) knows that we were successful.
+ set(IgnProtobuf_FOUND true)
diff --git a/dev-build/ignition-cmake/ignition-cmake-2.17.0.ebuild b/dev-build/ignition-cmake/ignition-cmake-2.17.0.ebuild
new file mode 100644
index 000000000000..31bbb9701296
--- /dev/null
+++ b/dev-build/ignition-cmake/ignition-cmake-2.17.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="CMake modules to be used by the Ignition projects"
+HOMEPAGE="https://github.com/ignitionrobotics/ign-cmake"
+SRC_URI="https://osrf-distributions.s3.amazonaws.com/ign-cmake/releases/${PN}2-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+PATCHES=( "${FILESDIR}/protobuf.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ "-DBUILD_TESTING=$(usex test)"
+ )
+ cmake_src_configure
+}
diff --git a/dev-build/ignition-cmake/metadata.xml b/dev-build/ignition-cmake/metadata.xml
new file mode 100644
index 000000000000..2e5e0cfa84ea
--- /dev/null
+++ b/dev-build/ignition-cmake/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="bitbucket">ignitionrobotics/ign-cmake</remote-id>
+ <remote-id type="github">ignitionrobotics/ign-cmake</remote-id>
+ </upstream>
+</pkgmetadata>