summaryrefslogtreecommitdiff
path: root/dev-build/bazelisk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-20 02:08:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-20 02:08:45 +0000
commitaec90632962b8bc48f23a1b5505d8afa0dfb6943 (patch)
tree7f137c721802f50a96c865424e51d1fb73d1baf4 /dev-build/bazelisk
parent2b2f431a0021b4787ca3c028cefb30ad81347778 (diff)
gentoo auto-resync : 20:01:2024 - 02:08:45
Diffstat (limited to 'dev-build/bazelisk')
-rw-r--r--dev-build/bazelisk/Manifest4
-rw-r--r--dev-build/bazelisk/bazelisk-1.19.0.ebuild38
-rw-r--r--dev-build/bazelisk/metadata.xml20
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-build/bazelisk/Manifest b/dev-build/bazelisk/Manifest
new file mode 100644
index 000000000000..3e302fa639f8
--- /dev/null
+++ b/dev-build/bazelisk/Manifest
@@ -0,0 +1,4 @@
+DIST bazelisk-1.19.0-deps.tar.xz 2414272 BLAKE2B d044bafa94ce8d4fd9bc6dceb76368653c5052ed579be6f6a6fd37c68c821442f86fabcebc88eff118a414bd99e0e9b49dde5321130107da9c3c3563e7cba01b SHA512 57bafd7bb370f49cf2ff90596e25be8672dc4ed4f8466f8a969b49ce6b1bc57d6aff917065ec07bb04c634efb259d8e045213acb04ba1288c6a5f2a441eb2607
+DIST bazelisk-1.19.0.tar.gz 166002 BLAKE2B 052411a9f43ce511980b0d15fc87b9abe652759aa5b90e420bb3b248f5ae287000c84fb86df21b950bfc708addb36c9b109042526fc3c88d2d6939ce3e9cfc1a SHA512 32e4401d685f46f2b6cf0a26165fedc1f2eef71bcea939f96e0c03f0bb20f666dc3c7a191df51f978b79fcba7941d6a4a5cd211d9e5a42d3b24e4704a6df890e
+EBUILD bazelisk-1.19.0.ebuild 754 BLAKE2B 23e220aa0461a9096bf2a82d3ebfe36e85cc7a765068eb0e3702b1a56178e7d59b3e0c88b51fe1e5f021f2dce207ceb9489f5d2a5c7562685c7b1a42661b9565 SHA512 10c7b11c6d94ed7a6e573fd78f4b1a35688e8f03caf3e73afea64128d23013ae24f67059cbc4390e4b3c1030aa2d7904682926f2c912ed561d87f6c9d266bd33
+MISC metadata.xml 793 BLAKE2B 5a20f80f4909ca23049c80a048ae53806e797716069116004e38df17e4b7d822115da04f70c680308e2093c4c6c785e0480ed1b070ad742161c20da019ee6900 SHA512 d717047a3f960cf54e996a090bcf38d12ec12ce1798977c0d64f224f81d2b864afc020919e5b8204004687d4ff69ef7e0391f04902d2006723044d4b41333077
diff --git a/dev-build/bazelisk/bazelisk-1.19.0.ebuild b/dev-build/bazelisk/bazelisk-1.19.0.ebuild
new file mode 100644
index 000000000000..21d65102b61a
--- /dev/null
+++ b/dev-build/bazelisk/bazelisk-1.19.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A user-friendly launcher for Bazel written in Go"
+HOMEPAGE="https://github.com/bazelbuild/bazelisk/"
+SRC_URI="
+ https://github.com/bazelbuild/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+src_compile() {
+ mkdir -p bin || die
+
+ local go_ldflags="-X main.BazeliskVersion=${PV}"
+ local -a go_buildargs=(
+ -ldflags "${go_ldflags}"
+ -o bin
+ )
+ ego build "${go_buildargs[@]}"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe "bin/${PN}"
+
+ einstalldocs
+}
diff --git a/dev-build/bazelisk/metadata.xml b/dev-build/bazelisk/metadata.xml
new file mode 100644
index 000000000000..032d00abaf95
--- /dev/null
+++ b/dev-build/bazelisk/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Bazelisk is a wrapper for Bazel written in Go. It automatically picks
+ a good version of Bazel given your current working directory, downloads it
+ from the official server (if required) and then transparently passes
+ through all command-line arguments to the real Bazel binary. You can call
+ it just like you would call Bazel.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/bazelbuild/bazelisk/issues/</bugs-to>
+ <remote-id type="github">bazelbuild/bazelisk</remote-id>
+ </upstream>
+</pkgmetadata>