summaryrefslogtreecommitdiff
path: root/dev-ada/xmlada/xmlada-2020.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-ada/xmlada/xmlada-2020.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-ada/xmlada/xmlada-2020.ebuild')
-rw-r--r--dev-ada/xmlada/xmlada-2020.ebuild93
1 files changed, 93 insertions, 0 deletions
diff --git a/dev-ada/xmlada/xmlada-2020.ebuild b/dev-ada/xmlada/xmlada-2020.ebuild
new file mode 100644
index 000000000000..cbc536004e3a
--- /dev/null
+++ b/dev-ada/xmlada/xmlada-2020.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ADA_COMPAT=( gnat_201{6,7,8,9} )
+inherit ada multiprocessing
+
+MYP=${P}-20200429-19A99-src
+
+DESCRIPTION="Set of modules that provide a simple manipulation of XML streams"
+HOMEPAGE="http://libre.adacore.com/"
+SRC_URI="https://community.download.adacore.com/v1/c799502295baf074ad17b48c50f621879c392c57?filename=${MYP}.tar.gz
+ -> ${MYP}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+shared static-libs static-pic"
+REQUIRED_USE="|| ( shared static-libs static-pic )
+ ${ADA_REQUIRED_USE}"
+
+RDEPEND="${ADA_DEPS}"
+DEPEND="${RDEPEND}
+ dev-ada/gprbuild[${ADA_USEDEP}]"
+
+S="${WORKDIR}"/${MYP}
+
+PATCHES=( "${FILESDIR}"/${PN}-2019-gentoo.patch )
+
+QA_FLAGS_IGNORED=(
+ /usr/lib/xmlada/xmlada_dom.relocatable/libxmlada_dom.so.2020
+ /usr/lib/xmlada/xmlada_input.relocatable/libxmlada_input_sources.so.2020
+ /usr/lib/xmlada/xmlada_sax.relocatable/libxmlada_sax.so.2020
+ /usr/lib/xmlada/xmlada_schema.relocatable/libxmlada_schema.so.2020
+ /usr/lib/xmlada/xmlada_unicode.relocatable/libxmlada_unicode.so.2020
+)
+
+src_configure() {
+ econf --prefix="${D}"/usr
+}
+
+src_compile() {
+ build () {
+ echo gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=$1 \
+ -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
+ -largs ${LDFLAGS} \
+ -cargs ${ADAFLAGS}
+ gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=$1 \
+ -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
+ -largs ${LDFLAGS} \
+ -cargs ${ADAFLAGS} || die "gprbuild failed"
+ }
+ if use shared; then
+ build relocatable
+ fi
+ if use static-libs; then
+ build static
+ fi
+ if use static-pic; then
+ build static-pic
+ fi
+}
+
+src_test() {
+ emake test
+ emake run_test | tee xmlada.testLog
+ grep -q DIFF xmlada.testLog && die
+}
+
+src_install() {
+ build () {
+ gprinstall -XLIBRARY_TYPE=$1 -f -p -XBUILD=Production \
+ -XPROCESSORS=$(makeopts_jobs) --prefix="${D}"/usr \
+ --install-name=xmlada --build-var=LIBRARY_TYPE \
+ --build-var=XMLADA_BUILD \
+ --build-name=$1 xmlada.gpr || die "gprinstall failed"
+ }
+ if use shared; then
+ build relocatable
+ fi
+ if use static-libs; then
+ build static
+ fi
+ if use static-pic; then
+ build static-pic
+ fi
+
+ einstalldocs
+ dodoc xmlada-roadmap.txt
+ rm -f "${D}"/usr/share/doc/${PN}/.buildinfo
+ rm -rf "${D}"/usr/share/gpr/manifests
+}