summaryrefslogtreecommitdiff
path: root/dev-ada/xmlada/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /dev-ada/xmlada/files
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'dev-ada/xmlada/files')
-rw-r--r--dev-ada/xmlada/files/xmlada-2018-gentoo.patch19
1 files changed, 15 insertions, 4 deletions
diff --git a/dev-ada/xmlada/files/xmlada-2018-gentoo.patch b/dev-ada/xmlada/files/xmlada-2018-gentoo.patch
index 9e79572e3067..439b85026d5f 100644
--- a/dev-ada/xmlada/files/xmlada-2018-gentoo.patch
+++ b/dev-ada/xmlada/files/xmlada-2018-gentoo.patch
@@ -1,5 +1,5 @@
---- xmlada-gpl-2017-src/Makefile.in.old 2017-12-04 20:09:23.730805855 +0100
-+++ xmlada-gpl-2017-src/Makefile.in 2017-12-04 20:09:51.586331155 +0100
+--- a/Makefile.in 2017-12-04 20:09:23.730805855 +0100
++++ b/Makefile.in 2017-12-04 20:09:51.586331155 +0100
@@ -62,7 +62,8 @@
# Rebuild the tests (and not the XML/Ada code itself)
@@ -9,8 +9,8 @@
-XTESTS_ACTIVATED=Only xmlada.gpr
# Run the tests. This requires an install of XML/Ada first
---- xmlada-gpl-2017-src/tests/Makefile.old 2017-12-04 21:38:29.722818904 +0100
-+++ xmlada-gpl-2017-src/tests/Makefile 2017-12-04 21:38:54.229382658 +0100
+--- a/tests/Makefile 2017-12-04 21:38:29.722818904 +0100
++++ b/tests/Makefile 2017-12-04 21:38:54.229382658 +0100
@@ -1,8 +1,6 @@
TESTS= test_unicode \
test_state \
@@ -28,3 +28,14 @@
gprbuild -q -Pdefault.gpr; \
./validate > $(RESULTS)/multiple_xsd.out; \
cp $(RESULTS)/multiple_xsd.out $(RESULTS)/multiple_xsd.diff; \
+--- a/input_sources/input_sources-http.adb 2019-05-29 10:18:23.428517625 +0200
++++ b/input_sources/input_sources-http.adb 2019-05-29 10:17:53.451007226 +0200
+@@ -191,7 +191,7 @@
+
+ Create_Socket (Socket);
+ Set_Socket_Option (Socket, Socket_Level, (Reuse_Address, True));
+- Set_Socket_Option (Socket, Option => (Receive_Buffer, 3000));
++ Set_Socket_Option (Socket, Socket_Level, (Receive_Buffer, 3000));
+ Connect_Socket (Socket, Addr);
+
+ Channel := Stream (Socket);