summaryrefslogtreecommitdiff
path: root/dev-ada/gnatcoll-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ada/gnatcoll-core
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ada/gnatcoll-core')
-rw-r--r--dev-ada/gnatcoll-core/Manifest4
-rw-r--r--dev-ada/gnatcoll-core/files/gnatcoll-core-2018-gentoo.patch22
-rw-r--r--dev-ada/gnatcoll-core/gnatcoll-core-2018.ebuild79
-rw-r--r--dev-ada/gnatcoll-core/metadata.xml29
4 files changed, 134 insertions, 0 deletions
diff --git a/dev-ada/gnatcoll-core/Manifest b/dev-ada/gnatcoll-core/Manifest
new file mode 100644
index 000000000000..66dea9241c31
--- /dev/null
+++ b/dev-ada/gnatcoll-core/Manifest
@@ -0,0 +1,4 @@
+AUX gnatcoll-core-2018-gentoo.patch 861 BLAKE2B 3bf6c4310fb02c20b780d7382fd8465774354c6132a0cc413d683fa2a2bdc8b0cc3dde2e7ca99dac8d00a231b002345d3be01e68da5c876f5d34c2f601ffc5c5 SHA512 4f211b71d5da88983d0c111aafc48c12c9486dec854e903f4ad352d61a48c097994aaf5679c42fb8f74a35c35d73ef6c33e814bf6ea391538ab4e3b5d1253368
+DIST gnatcoll-core-gpl-2018-src.tar.gz 1657129 BLAKE2B 616aef931fb542f4a022c63db53acb0f8b4323e3b948eb7b8b5688c36817b3f52b5f517b969b0560b6492d51a3e59c8350449cbbe7246b5294c45caeead4d9d6 SHA512 bf6082573dc537836ea8506a2c9a75dc7837440c35c5b02a52add52e38290d99e90a9706690591f8899b8b4935824b195f230b3aa1c4da10911e3caf954c04ac
+EBUILD gnatcoll-core-2018.ebuild 1675 BLAKE2B 913974fecd9ede02d75193a2fe577a078ad771d53cf04f987ef4b6d036f79d9296e382b44bab0ae8d546b78996a16b4c75d3f42a04516babc2c1b7f5ddc7776a SHA512 422c0ceff9792bf92af4746b108e40f39427bc2904ffcda4df3449a6aa5bffd2e049fb7d84666f68716824566a87e3b990a74233e330bc378fac44ddebd25ba6
+MISC metadata.xml 1331 BLAKE2B 0227dacfedf39550b497596c95191f5c8524b9aaaaa19dbab296f4e34fe3ff3ea32f4f92a40c16194204661229986ad90a527131d4bb97decf1b6bd59b911884 SHA512 008d3836de7baa71b8d3655e3e7834d68a7ec304345bfda8a715416e46fa5255185336f84f6b75dbf7a85d24afebd0fdb85131b52ce7c655635e09b42bc1907e
diff --git a/dev-ada/gnatcoll-core/files/gnatcoll-core-2018-gentoo.patch b/dev-ada/gnatcoll-core/files/gnatcoll-core-2018-gentoo.patch
new file mode 100644
index 000000000000..cedf710c0363
--- /dev/null
+++ b/dev-ada/gnatcoll-core/files/gnatcoll-core-2018-gentoo.patch
@@ -0,0 +1,22 @@
+--- a/gnatcoll.gpr 2018-06-12 21:37:42.664733336 +0200
++++ b/gnatcoll.gpr 2018-06-12 21:38:07.965360000 +0200
+@@ -115,6 +115,7 @@
+
+ for Switches ("gnatcoll_support.c") use
+ Compiler'Switches ("C") & Extra_Switches;
++ for Driver ("C") use External ("GCC", "gcc");
+
+ end Compiler;
+
+--- a/src/gnatcoll-projects.ads.old 2017-11-25 14:50:06.919939453 +0100
++++ b/src/gnatcoll-projects.ads 2017-11-25 14:50:38.932387204 +0100
+@@ -1917,7 +1917,8 @@
+ Predefined_Source_Files : GNATCOLL.VFS.File_Array_Access;
+ -- The list of source files in Predefined_Source_Path
+
+- Default_Gnatls : GNAT.Strings.String_Access := new String'("gnatls");
++ Default_Gnatls : GNAT.Strings.String_Access :=
++ new String'("@GNATLS@");
+ -- The default gnatls command to run.
+
+ Xrefs_Subdir : GNAT.Strings.String_Access;
diff --git a/dev-ada/gnatcoll-core/gnatcoll-core-2018.ebuild b/dev-ada/gnatcoll-core/gnatcoll-core-2018.ebuild
new file mode 100644
index 000000000000..88fa2a1f45ac
--- /dev/null
+++ b/dev-ada/gnatcoll-core/gnatcoll-core-2018.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit multiprocessing
+
+MYP=${PN}-gpl-${PV}
+
+DESCRIPTION="GNAT Component Collection Core packages"
+HOMEPAGE="http://libre.adacore.com"
+SRC_URI="http://mirrors.cdn.adacore.com/art/5b0819dfc7a447df26c27a99
+ -> ${MYP}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnat_2016 gnat_2017 +gnat_2018 +shared static-libs static-pic"
+
+RDEPEND="
+ dev-ada/libgpr[gnat_2016=,gnat_2017=,gnat_2018=]
+ dev-ada/libgpr[shared?,static-libs?,static-pic?]
+ !dev-ada/gnatcoll"
+DEPEND="${RDEPEND}
+ dev-ada/gprbuild[gnat_2016=,gnat_2017=,gnat_2018=]"
+
+REQUIRED_USE="!gnat_2016"
+
+S="${WORKDIR}"/${MYP}-src
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_prepare() {
+ if use gnat_2017; then
+ GCC_PV=6.3.0
+ else
+ GCC_PV=7.3.1
+ fi
+ default
+ sed -i \
+ -e "s:@GNATLS@:${CHOST}-gnatls-${GCC_PV}:g" \
+ src/gnatcoll-projects.ads \
+ || die
+}
+
+src_configure() {
+ emake prefix="${D}usr" PROCESSORS=$(makeopts_jobs) setup
+}
+
+src_compile() {
+ build () {
+ GCC=${CHOST}-gcc-${GCC_PV} gprbuild -p -m -j$(makeopts_jobs) \
+ -XBUILD=PROD -v -XGNATCOLL_VERSION=${PV} \
+ -XLIBRARY_TYPE=$1 -XXMLADA_BUILD=$* -XGPR_BUILD=$1 \
+ gnatcoll.gpr -cargs:C ${CFLAGS} -cargs:Ada ${ADAFLAGS} || die
+ }
+ if use shared; then
+ build relocatable
+ fi
+ if use static-pic; then
+ build static-pic
+ fi
+ if use static-libs; then
+ build static
+ fi
+}
+
+src_install() {
+ if use shared; then
+ emake install-relocatable
+ fi
+ if use static-pic; then
+ emake install-static-pic
+ fi
+ if use static-libs; then
+ emake install-static
+ fi
+ rm -r "${D}"/usr/share/gpr/manifests || die
+ einstalldocs
+}
diff --git a/dev-ada/gnatcoll-core/metadata.xml b/dev-ada/gnatcoll-core/metadata.xml
new file mode 100644
index 000000000000..294071cbcd12
--- /dev/null
+++ b/dev-ada/gnatcoll-core/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <use>
+ <flag name="gnat_2016">Compile with dev-lang/gnat-gpl-2016</flag>
+ <flag name="gnat_2017">Compile with dev-lang/gnat-gpl-2017</flag>
+ <flag name="gnat_2018">Compile with dev-lang/gnat-gpl-2018</flag>
+ <flag name="shared">Build shared library</flag>
+ <flag name="static-pic">Build static library with pic code</flag>
+ </use>
+ <longdescription lang="en">
+ The reusable library known as the GNAT Component Collection (GNATColl)
+ is based on one main principle: general-purpose packages that are part
+ of the GNAT technology should also be available to GNAT user
+ application code. The compiler front end, the GNAT Programming Studio
+ (GPS) Interactive Development Environment, and the GNAT Tracker
+ web-based interface all served as sources for the components.
+
+ The GNATColl components complement the predefined Ada and GNAT
+ libraries and deal with a range of common programming issues including
+ string and text processing, memory management, and file handling.
+ Several of the components are especially useful in enterprise
+ applications.
+ </longdescription>
+</pkgmetadata>