summaryrefslogtreecommitdiff
path: root/dev-ada/e3-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ada/e3-core
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ada/e3-core')
-rw-r--r--dev-ada/e3-core/Manifest5
-rw-r--r--dev-ada/e3-core/e3-core-22.1.0.ebuild49
-rw-r--r--dev-ada/e3-core/files/e3-core-22.1.0-distro.patch30
-rw-r--r--dev-ada/e3-core/files/e3-core-22.1.0-test.patch28
-rw-r--r--dev-ada/e3-core/metadata.xml28
5 files changed, 140 insertions, 0 deletions
diff --git a/dev-ada/e3-core/Manifest b/dev-ada/e3-core/Manifest
new file mode 100644
index 000000000000..ec93792eb752
--- /dev/null
+++ b/dev-ada/e3-core/Manifest
@@ -0,0 +1,5 @@
+AUX e3-core-22.1.0-distro.patch 1143 BLAKE2B ebe7fd0b37ed6dbbe506f4bb86aa8b3bbf59b5e1475b65db07b2a8b28ab86f30998f381c976e9b1eb0f5222171a3c6a592bf7d6a3364a0a0a6c1eb307c0261ef SHA512 16ba2640ecb260702272da1d87b92ce779459da47ef4c1cdc6ad4f5fe98740501df88bc2ef849c55f0eb482a99ab376876af1f5a38a02fe0aeef085c190ecba0
+AUX e3-core-22.1.0-test.patch 1057 BLAKE2B 4a8d5ea01e2cd51c297f58db18a25844197bdbaa725260de3eeace06dc3afa74332f10df685947b8bb21e4554920c72eb2c5d08d334d2f77989241510ee00098 SHA512 0771e4d08c611c3b39a695830a30b279470a97e0ccc4c2d6ef0ed184bcbc784240231a93942b89919b4718ed8ede1d3e7b9ff9acf66b547b369fa702cc05f384
+DIST e3-core-22.1.0.tar.gz 442938 BLAKE2B b207a09d8b97f707e8b3a6255b9ef7161e40f716a8bcd853923df2310f2413689ddadf9db98e90f103f8a93813eec20bf462e47541d6f409df5966b0b1d9fca7 SHA512 e887fea2140bb42ebc9d8596b87dc077f8da6a0ed4178081aedaaf3f462b76a431c53e6e56bcb7efee2ed3854c50d7b989819b469b394977d6d25f644368f12d
+EBUILD e3-core-22.1.0.ebuild 1291 BLAKE2B 2f8fa7f274a58af1bd73c6350b3747b9634401613cdcdb02227979e5b800935d2fd98d1042ccbe856d437ca99e494ace29f6b65223a5dd0241859f3fccde6b77 SHA512 3c7762983509600465a6470de4e3586faf29b3740b3e7d785887c49c5f1c36873d5f509967634b509b0942370702a5c6bf62ccb3c6848293251062c8e4c7ca58
+MISC metadata.xml 1257 BLAKE2B c5170ed783bde8d288632069c3e5496d50dfd77a0f7fb62e00964660bd7b3c482509bdf8983af16d1aa7be6bd9ee20708711fc688f002d5bace078c93c4ed212 SHA512 d7fd1018cb701d777e3246fe91b018ea25ebd5bc641e6897d683dee0fcfdd1841d13f9701212d15e81cde531f8e26d10cc156c9ed47125dfbcbc6bd5bacf18af
diff --git a/dev-ada/e3-core/e3-core-22.1.0.ebuild b/dev-ada/e3-core/e3-core-22.1.0.ebuild
new file mode 100644
index 000000000000..80324535319e
--- /dev/null
+++ b/dev-ada/e3-core/e3-core-22.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Ease the development of portable automated build systems"
+HOMEPAGE="https://www.adacore.com/"
+SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ !app-editors/e3"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ dev-vcs/subversion
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-distro.patch
+ "${FILESDIR}"/${P}-test.patch
+)
+
+distutils_enable_tests --install pytest
+
+src_compile() {
+ local PLATFORM=x86_64-linux
+ rm src/e3/os/data/rlimit* || die
+ $(tc-getCC) ${CFLAGS} -o src/e3/os/data/rlimit-${PLATFORM} tools/rlimit/rlimit.c ${LDFLAGS}
+ distutils-r1_src_compile
+}
diff --git a/dev-ada/e3-core/files/e3-core-22.1.0-distro.patch b/dev-ada/e3-core/files/e3-core-22.1.0-distro.patch
new file mode 100644
index 000000000000..05942a8f8e7d
--- /dev/null
+++ b/dev-ada/e3-core/files/e3-core-22.1.0-distro.patch
@@ -0,0 +1,30 @@
+--- a/src/e3/os/platform.py 2021-11-23 08:50:05.077801145 +0100
++++ b/src/e3/os/platform.py 2021-11-23 08:50:40.646227489 +0100
+@@ -85,12 +85,12 @@
+
+ # Fetch linux distribution info on linux OS
+ if cls.uname.system == "Linux": # linux-only
+- import ld
++ import distro
+
+ cls.ld_info = {
+- "name": ld.name(),
+- "major_version": ld.major_version(),
+- "version": ld.version(),
++ "name": distro.name(),
++ "major_version": distro.major_version(),
++ "version": distro.version(),
+ }
+
+ # Fetch network interfaces
+--- a/setup.py 2021-11-23 20:36:57.056478696 +0100
++++ b/setup.py 2021-11-23 20:36:03.371303043 +0100
+@@ -18,7 +18,7 @@
+ platform_string = ":sys_platform=='%s'" % p
+ extras_require[platform_string] = ["psutil"]
+ if p in ("linux", "linux2"):
+- extras_require[platform_string].append("ld")
++ extras_require[platform_string].append("distro")
+
+ # Get e3 version from the VERSION file.
+ version_file = os.path.join(os.path.dirname(__file__), "VERSION")
diff --git a/dev-ada/e3-core/files/e3-core-22.1.0-test.patch b/dev-ada/e3-core/files/e3-core-22.1.0-test.patch
new file mode 100644
index 000000000000..84250e1379c8
--- /dev/null
+++ b/dev-ada/e3-core/files/e3-core-22.1.0-test.patch
@@ -0,0 +1,28 @@
+--- a/tests/tests_e3/main/main_test.py 2021-11-23 21:43:12.376707596 +0100
++++ b/tests/tests_e3/main/main_test.py 2021-11-23 21:45:08.653856916 +0100
+@@ -15,6 +15,7 @@
+ )
+
+
++@pytest.mark.xfail(reason="does not work on sandbox")
+ def test_main_config():
+ os.environ["E3_CONFIG"] = "e3.toml"
+ assert "pretty: True" in e3.os.process.Run(["e3", "--show-config"]).out
+--- a/tests/tests_e3/sys/main_test.py 2021-11-23 21:51:32.633747623 +0100
++++ b/tests/tests_e3/sys/main_test.py 2021-11-23 21:51:43.977567183 +0100
+@@ -10,6 +10,7 @@
+ import pytest
+
+
++@pytest.mark.xfail(reason="does not work on sandbox")
+ def test_filtering_import():
+ script = """
+ import a, b, c
+--- a/tests/tests_e3/system/main_test.py 2021-11-23 22:16:33.776844819 +0100
++++ b/tests/tests_e3/system/main_test.py 2021-11-23 22:17:38.292817661 +0100
+@@ -4,5 +4,3 @@
+
+ def test_main():
+ e3_tool = e3.sys.python_script("e3")
+- assert e3.os.process.Run(e3_tool + ["--version"]).status == 0
+- assert "Everything OK!" in e3.os.process.Run(e3_tool + ["--check"]).out
diff --git a/dev-ada/e3-core/metadata.xml b/dev-ada/e3-core/metadata.xml
new file mode 100644
index 000000000000..bfc1b11cee7c
--- /dev/null
+++ b/dev-ada/e3-core/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ada@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ This present project (e3) is a Python framework to ease the
+ development of portable automated build systems (compilation,
+ dependencies management, binary code packaging, and automated
+ testing).
+ The e3 framework is split across multiple Python packages named
+ e3-name and sharing the same namespace: e3.
+ e3-core contains several packages that help writing portable code
+ running on both Windows and UNIX systems. It also contains Anod, a
+ build and test driver based on Anod specification files that handle
+ dependencies management, create binary packages, and execute test
+ suites. The driver inputs are Python files ending with .anod called
+ Anod specification files describing:
+ dependencies (either for building, installing, or testing a product)
+ required Git or Subversion repositories
+ list of action to execute for each of the Anod actions or primitives
+ (build, install, test, …)
+ </longdescription>
+ <upstream>
+ <remote-id type="github">adacore/e3-core</remote-id>
+ </upstream>
+</pkgmetadata>