summaryrefslogtreecommitdiff
path: root/dev-ada/aunit/aunit-2019-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-ada/aunit/aunit-2019-r1.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-ada/aunit/aunit-2019-r1.ebuild')
-rw-r--r--dev-ada/aunit/aunit-2019-r1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-ada/aunit/aunit-2019-r1.ebuild b/dev-ada/aunit/aunit-2019-r1.ebuild
deleted file mode 100644
index ebb8f8545ce4..000000000000
--- a/dev-ada/aunit/aunit-2019-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ADA_COMPAT=( gnat_201{6,7,8,9} )
-inherit ada multiprocessing
-
-MYP=${P}-20190429-18B77-src
-
-DESCRIPTION="Ada unit testing framework"
-HOMEPAGE="http://libre.adacore.com/tools/aunit/"
-SRC_URI="http://mirrors.cdn.adacore.com/art/5cdf859431e87aa2cdf16b18
- -> ${MYP}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND="${ADA_DEPS}"
-DEPEND="${RDEPEND}
- dev-ada/gprbuild[${ADA_USEDEP}]"
-
-REQUIRED_USE="${ADA_REQUIRED_USE}"
-
-S="${WORKDIR}"/${MYP}
-
-PATCHES=( "${FILESDIR}"/${PN}-2016-gentoo.patch )
-
-src_compile() {
- emake GPRBUILD="gprbuild -j$(makeopts_jobs) -v"
-}
-
-src_install() {
- emake INSTALL="${D}"/usr install
- einstalldocs
- mv "${D}"/usr/share/doc/${PN}/* "${D}"/usr/share/doc/${PF}/ || die
- rmdir "${D}"/usr/share/doc/${PN} || die
- mv "${D}"/usr/share/examples/${PN} "${D}"/usr/share/doc/${PF}/examples || die
- rmdir "${D}"/usr/share/examples || die
- rm -r "${D}"/usr/share/gpr/manifests || die
-}
-
-src_test() {
- emake PROJECT_PATH_ARG="ADA_PROJECT_PATH=$(pwd)/lib/gnat" -C test
-}