summaryrefslogtreecommitdiff
path: root/dev-ada/asis/asis-2017.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /dev-ada/asis/asis-2017.ebuild
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'dev-ada/asis/asis-2017.ebuild')
-rw-r--r--dev-ada/asis/asis-2017.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/dev-ada/asis/asis-2017.ebuild b/dev-ada/asis/asis-2017.ebuild
index 82141cacc339..80f51a94f66e 100644
--- a/dev-ada/asis/asis-2017.ebuild
+++ b/dev-ada/asis/asis-2017.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,7 +13,7 @@ SRC_URI="http://mirrors.cdn.adacore.com/art/591c45e2c7a447af2deecffb
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE="gnat_2016 +gnat_2017"
DEPEND="dev-ada/gnat_util[gnat_2017]
@@ -30,10 +30,16 @@ PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
src_compile() {
emake PROCESSORS=$(makeopts_jobs)
- emake tools PROCESSORS=$(makeopts_jobs)
+ emake tools PROCESSORS=$(makeopts_jobs) \
+ GPRBUILD_FLAGS="-vl \
+ -XLIBRARY_TYPE=relocatable \
+ -XXMLADA_BUILD=relocatable"
}
src_install() {
emake prefix="${D}"/usr install
- emake prefix="${D}"/usr install-tools
+ emake prefix="${D}"/usr install-tools \
+ GPRINSTALL="gprinstall \
+ -XLIBRARY_TYPE=relocatable \
+ -XXMLADA_BUILD=relocatable"
}