summaryrefslogtreecommitdiff
path: root/app-vim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /app-vim
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/Manifest.gzbin32590 -> 32598 bytes
-rw-r--r--app-vim/gentoo-syntax/Manifest2
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20190609.ebuild42
3 files changed, 44 insertions, 0 deletions
diff --git a/app-vim/Manifest.gz b/app-vim/Manifest.gz
index 10bb5b0d8738..c6bacf5954ee 100644
--- a/app-vim/Manifest.gz
+++ b/app-vim/Manifest.gz
Binary files differ
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index c8c8a6fb7dea..f6a5a25eec07 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,4 +1,6 @@
DIST gentoo-syntax-20181023.tar.bz2 18299 BLAKE2B ea037425ab00b05e4a52f943817fb264492793c842b6c9250450ab715fafebc55d0b5b95ff49945f62258f2dc70f357eeef3a5d908592c995cdc6e940f2f15af SHA512 a6bd592dd46ad80a4126321826dbbc4c130624027e7e71f0ea87fb164963e980e3ab3e1db1e87ee0ddad602f2ea2e9e7d955a0016c00eb8aef4c01c29057b737
+DIST gentoo-syntax-20190609.tar.bz2 18401 BLAKE2B db738540fc85d8edd0269ade33e174db08b9231237f1138da9a3f6ecff7c188a041b312975629be652a5384d0c914ad8d7a3ac5ef14670e4bc0859fbdf3dcbc7 SHA512 70fbf6e37eee2e5b007eb59b76492f41046884a8310a6074ca5fbab666ec74d46ab3e57bbf2ae784db2e17bfd1c4801b18b71cf37f746e02ff640de1f6821ec7
EBUILD gentoo-syntax-20181023.ebuild 1289 BLAKE2B eb217dfaed0680a9dd2e4c6727ee4f07255b04187887f5cff6eada0b56a77ba290173db5394212fe6700750bf9dc73d68170be347f2590723b8c381d2e0e42c9 SHA512 0992ed4df494b14567d259b65e6d15978e3f92f29d54f72c7f72920bbdb2d8fa796d4bfd659b5653c522998eb7f4073a688da84aa1637fa2f6409107f8a880f1
+EBUILD gentoo-syntax-20190609.ebuild 1302 BLAKE2B f38ff2cc4a3f1f7721aaa7fa0dc52cd3dab579f42cccd1e21251d06f4c2791d8e96e3ac5398e1a0bff9ba0880aab238728157850ed9c2f7e535dafe88668d060 SHA512 e4314a6092df220f6fdac1961444eaef82f46f318ffc6f3b81d447934c692ea9a741fc09356218590f20e0fb1992ba3099ee9285c2a656b99a6718b70cb6b94d
EBUILD gentoo-syntax-99999999.ebuild 1087 BLAKE2B 9b7c64f1ec0215aa53e39c0c4db8352c47b19ee89a894dc95ef4a867415337ff901befaadf2ce468804e4167410c1d034002ca476c90925096875b3dc27b8868 SHA512 5f0e991bcc491e807ea86d89c47dcc8d6879c35d0f42d191a4e2cd4d40f117022e70cfb92503184e638273daed9780363066d07667c138592be1e1b6f4435b99
MISC metadata.xml 560 BLAKE2B 21f954af20949469ae0f30a81743d9bdd1114b64b51b640d0da2d294897a885878a13bb1d408c69cd9e1afe936fd02c1ae7170e48a2f5d2280afe525266e448a SHA512 89d979077e4171aece29bd44f3d6ab6a84261dfa8eaa655b5b5d77dc20c5e2ea7cd361002e0f4d8212793449bd86da03e2d2e59bc6d23a158dceca1d60d416fe
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20190609.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20190609.ebuild
new file mode 100644
index 000000000000..c134f1d2e57d
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20190609.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}