summaryrefslogtreecommitdiff
path: root/app-vim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /app-vim
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/Manifest.gzbin32408 -> 32574 bytes
-rw-r--r--app-vim/vim-jsonnet/Manifest3
-rw-r--r--app-vim/vim-jsonnet/metadata.xml11
-rw-r--r--app-vim/vim-jsonnet/vim-jsonnet-0_pre20190502.ebuild24
4 files changed, 38 insertions, 0 deletions
diff --git a/app-vim/Manifest.gz b/app-vim/Manifest.gz
index a3c3bb7404d4..bb15bcb778bb 100644
--- a/app-vim/Manifest.gz
+++ b/app-vim/Manifest.gz
Binary files differ
diff --git a/app-vim/vim-jsonnet/Manifest b/app-vim/vim-jsonnet/Manifest
new file mode 100644
index 000000000000..591b9419ae47
--- /dev/null
+++ b/app-vim/vim-jsonnet/Manifest
@@ -0,0 +1,3 @@
+DIST vim-jsonnet-0_pre20190502.tar.gz 102599 BLAKE2B 14f9fd72e6791fbd78b3749f860115a9a63137f7dc5e2d1eabae45b777dcebd902c9fa100665e2447ad0d6c8cd4e117beefc2bf16efd98c3382c84a2ebdc3951 SHA512 cac7b41cdd1749eab575cfdd0e897b37f2c842b69ad4a62c355c231d8d93668ab2e9929893bea72697ca512bf40a7768019b28866643025505abc421fbea12ec
+EBUILD vim-jsonnet-0_pre20190502.ebuild 560 BLAKE2B 53724664edfda06d0403e423ae5f0213a4ebfdea7f98fba359cdcee617a6f602930492c0d596b85d9833177e6c56f594845c0d004682fdcf2be80107c94d123f SHA512 2220c396a880fafca6730f730e0d6b562aa90ad6cb83931e5f8f275aed877eb5930ce9dbd49cea2d9ed5068917d557f15935cb9f99d39f168986edc74acf7e11
+MISC metadata.xml 342 BLAKE2B 82d07055b4838f03a591b6d23265fda68ddca33aa499cec3a90c889119349002c68365d6b01df34a630995b37d3bb4c960d57d74f96a9224f2ad0e7d1c3f5ff2 SHA512 674bbab5db8ca711eec0685759117032aca12d58dc4e32403829d3fcdd4361b8e4b5180c80abad198eccf0189dc51ff51ed3f59278580afddaf1267d35d304dc
diff --git a/app-vim/vim-jsonnet/metadata.xml b/app-vim/vim-jsonnet/metadata.xml
new file mode 100644
index 000000000000..81356ad8ead3
--- /dev/null
+++ b/app-vim/vim-jsonnet/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">google/vim-jsonnet</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vim-jsonnet/vim-jsonnet-0_pre20190502.ebuild b/app-vim/vim-jsonnet/vim-jsonnet-0_pre20190502.ebuild
new file mode 100644
index 000000000000..df90ee8b9a49
--- /dev/null
+++ b/app-vim/vim-jsonnet/vim-jsonnet-0_pre20190502.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+COMMIT_HASH="824dcfe76568dba38135332fc4729e2b2c4d9b3a"
+
+DESCRIPTION="vim plugin: Filetype plugin for dev-lang/jsonnet"
+HOMEPAGE="https://github.com/google/vim-jsonnet"
+SRC_URI="https://github.com/google/vim-jsonnet/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/jsonnet"
+
+S="${WORKDIR}/${PN}-${COMMIT_HASH}"
+
+src_prepare() {
+ default
+
+ rm -f LICENSE .gitignore || die
+}