summaryrefslogtreecommitdiff
path: root/app-vim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /app-vim
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/Manifest.gzbin31933 -> 31934 bytes
-rw-r--r--app-vim/command-t/Manifest1
-rw-r--r--app-vim/command-t/command-t-5.0.3-r1.ebuild47
3 files changed, 48 insertions, 0 deletions
diff --git a/app-vim/Manifest.gz b/app-vim/Manifest.gz
index 10725b7f1943..75840c1099aa 100644
--- a/app-vim/Manifest.gz
+++ b/app-vim/Manifest.gz
Binary files differ
diff --git a/app-vim/command-t/Manifest b/app-vim/command-t/Manifest
index 86a7fb2a3256..17cefccc0cb8 100644
--- a/app-vim/command-t/Manifest
+++ b/app-vim/command-t/Manifest
@@ -1,3 +1,4 @@
DIST command-t-5.0.3.tar.gz 84019 BLAKE2B fec893aa698a1d1bfc86cf7bd08562f19b54e58d81b7650e50acdf17bfcec54f78aae38d05ca5f93ae60c981a6e606d5c68c008be3508c7d41e74aa9f064943a SHA512 588ee1516039e6cd45210de43307c02259fed29cc7610c222fe705cdf1d5938f51f823d41b546a36320da31db12e902363867da91b18fe56ea09c1efe2bb51fb
+EBUILD command-t-5.0.3-r1.ebuild 1231 BLAKE2B 9afdf59212b3d02bc2a898ed31f2acd619242badef9823c8dda2e0135bf4b65a509e22a4a4e03b650f78fb2fee304ee9e8dc341f543ac6b2d0d3581c83792331 SHA512 76fbed23a6e345342a236311051ebdcf3c2330a8b5dec7a8e34d43d9eed2ed3aab334f4b13c6dc03f45405a49c102925ed1d5067ab8068ece73ab36ae89f22a0
EBUILD command-t-5.0.3.ebuild 1231 BLAKE2B d275f621c31913875f1e3fe8481c6753ca08765e26b2ca3a71018ba27d0c14d49368e2e29679a4c65b06fa9c850fe37cc57d4c3c68bb2393ee057e90e8334402 SHA512 6ae0e3aea757eba418ecccaeb362f0ea9e19d1ffd5b0ea3197f9b772ea747aaa97bfe5995720f068a2a4b7b27ae8d2d37b01f75b0f530217f708662633442a37
MISC metadata.xml 331 BLAKE2B a65f2e6cff106416168097ba58849fc3f88f9fcfe01c7d6e201344fd77d5ac36ddac46400359542522b7fe8e9c52f43d4f562b7285d32919f10f781a5282902c SHA512 07c9de3f662f3acf4bac7f8b8eac6fec536241d55084346b4cb2a78665165477573a6ae2570fd606abb11cdfb66d76785714e6475c396da0506291eaaa648236
diff --git a/app-vim/command-t/command-t-5.0.3-r1.ebuild b/app-vim/command-t/command-t-5.0.3-r1.ebuild
new file mode 100644
index 000000000000..88a26579c200
--- /dev/null
+++ b/app-vim/command-t/command-t-5.0.3-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+inherit vim-plugin ruby-ng
+
+DESCRIPTION="vim plugin: fast file navigation for vim"
+HOMEPAGE="https://vim.sourceforge.io/scripts/script.php?script_id=3025 https://github.com/wincent/command-t"
+SRC_URI="https://github.com/wincent/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="|| ( app-editors/vim[ruby] app-editors/gvim[ruby] )"
+
+all_ruby_prepare() {
+ find "${S}" -name .gitignore -delete || die
+}
+
+each_ruby_configure() {
+ cd ruby/${PN}/ext/${PN} || die
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ cd ruby/${PN}/ext/${PN} || die
+ emake V=1
+ rm *.o *.c *.h *.log extconf.rb depend Makefile || die
+}
+
+each_ruby_install() {
+ local sitelibdir=$(ruby_rbconfig_value "sitelibdir")
+ insinto "${sitelibdir}"
+ doins -r ruby/${PN}/{ext,lib}/*
+}
+
+all_ruby_install() {
+ rm -r appstream bin fixtures data ruby/${PN}/{ext,lib,*.gemspec} spec vendor || die
+
+ vim-plugin_src_install
+
+ # make sure scripts are executable
+ chmod +x "${ED}"/usr/share/vim/vimfiles/ruby/${PN}/bin/* || die
+}