summaryrefslogtreecommitdiff
path: root/app-vim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
commit70b82ae359a5538711e103b0e8dfb92654296644 (patch)
tree8412b84ff9ce02a22be5251052b00feefe1d5b70 /app-vim
parent64e107b9b6058580ff0432107eb37cefb0b2a7d8 (diff)
gentoo resync : 27.10.2018
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/Manifest.gzbin32450 -> 32453 bytes
-rw-r--r--app-vim/gentoo-syntax/Manifest2
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20181023.ebuild42
3 files changed, 44 insertions, 0 deletions
diff --git a/app-vim/Manifest.gz b/app-vim/Manifest.gz
index 343fed96d885..a8fa8679c724 100644
--- a/app-vim/Manifest.gz
+++ b/app-vim/Manifest.gz
Binary files differ
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index fca25e3faca1..bdaceac33394 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,4 +1,6 @@
DIST gentoo-syntax-20180821.tar.bz2 18361 BLAKE2B 4134fd0a3d75d86f3984f135021063b68588083f191efcb94d7b599460703d6eb501bad7de2aa0cc9cdc4447d73b83e4b36cee2acdd113e7d0a879e1e864e2fb SHA512 09c70ded667b489e03f02e0e72fca32f13a40501a5e319b387967e75f616c7f3dc44ceab3a46b776a509263f58668223eb85d51ba58ca3fbc48e4c05d7345dfc
+DIST gentoo-syntax-20181023.tar.bz2 18299 BLAKE2B ea037425ab00b05e4a52f943817fb264492793c842b6c9250450ab715fafebc55d0b5b95ff49945f62258f2dc70f357eeef3a5d908592c995cdc6e940f2f15af SHA512 a6bd592dd46ad80a4126321826dbbc4c130624027e7e71f0ea87fb164963e980e3ab3e1db1e87ee0ddad602f2ea2e9e7d955a0016c00eb8aef4c01c29057b737
EBUILD gentoo-syntax-20180821.ebuild 1283 BLAKE2B 833c4fd4b2bc85a87359f188f86db454dafb1938183c4b65905d0cde2dc4099a0ba4e5cfbc4a99a18bd89f0d57ff47df48f4ad3a687b9aaa2309d22c57a1624e SHA512 b7af1703f420fed2e2a890e86e78e68037ff1405f55d7c8ec56a63c7466b998f1c9f024ae342ef45e301f8fe2acb5731c2bf941fb7a58ffdb67986dee9d4c69e
+EBUILD gentoo-syntax-20181023.ebuild 1295 BLAKE2B 5240108071b06075d11335c1877faf4a56b6065baadece201b71ae4b92ba92d098d8fd085882c0365e80f284f18c2f053b1fc469278bec7279f08f79c4b4961a SHA512 1bbacc8c4467ea60888c4d82aa767830d8acca09b532b6bafb00c978220b780c20f7c108201240cf9b638ce73ad5196e6a8c184029d22f95e86c65baef8eca6e
EBUILD gentoo-syntax-99999999.ebuild 1087 BLAKE2B 9b7c64f1ec0215aa53e39c0c4db8352c47b19ee89a894dc95ef4a867415337ff901befaadf2ce468804e4167410c1d034002ca476c90925096875b3dc27b8868 SHA512 5f0e991bcc491e807ea86d89c47dcc8d6879c35d0f42d191a4e2cd4d40f117022e70cfb92503184e638273daed9780363066d07667c138592be1e1b6f4435b99
MISC metadata.xml 560 BLAKE2B 21f954af20949469ae0f30a81743d9bdd1114b64b51b640d0da2d294897a885878a13bb1d408c69cd9e1afe936fd02c1ae7170e48a2f5d2280afe525266e448a SHA512 89d979077e4171aece29bd44f3d6ab6a84261dfa8eaa655b5b5d77dc20c5e2ea7cd361002e0f4d8212793449bd86da03e2d2e59bc6d23a158dceca1d60d416fe
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20181023.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20181023.ebuild
new file mode 100644
index 000000000000..c40de243f4b0
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20181023.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}