summaryrefslogtreecommitdiff
path: root/app-vim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /app-vim
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/Manifest.gzbin31932 -> 31940 bytes
-rw-r--r--app-vim/gentoo-syntax/Manifest2
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20210716.ebuild42
-rw-r--r--app-vim/salt-vim/Manifest2
-rw-r--r--app-vim/salt-vim/salt-vim-20151119.ebuild2
5 files changed, 46 insertions, 2 deletions
diff --git a/app-vim/Manifest.gz b/app-vim/Manifest.gz
index 9ca8912fbe07..d1b539e4f573 100644
--- a/app-vim/Manifest.gz
+++ b/app-vim/Manifest.gz
Binary files differ
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index ba84b2ee2238..0ff000844dd4 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,4 +1,6 @@
DIST gentoo-syntax-20210428.tar.bz2 18737 BLAKE2B 437bf954e2bca61e3f612761a056de3c248d8f1f7afd3d07fab01770b1ff6e0ed8adb7222a61683770f369392d2c6f52ec5594b946c9e7a69d1cc1f6033caa5b SHA512 db64f53e0c6dd0c9b7fa9142422e4b24f037e9fb012235756443556a20a2bbce9c0b712a5375f482d3caf83760bc96239afc17a1a4f2ad89e9a6166063c6af68
+DIST gentoo-syntax-20210716.tar.bz2 18872 BLAKE2B faef2f356331c8560cb8e8014ad1a32a299f94fe8d05be499955cb78f1537f85abe44864b782df34244c3e606443b2146bd58a55047b23d327a548a436e818dc SHA512 f1a374fb5cf05563ea8cafa2209c9e8ba62bc072cac99202f486c3f7412cbb63432a33830e285ba706f8f73ee7f7bfd4e0b30bfad6feee1643e862b86495b82e
EBUILD gentoo-syntax-20210428.ebuild 1238 BLAKE2B 3916495228ba1ec18105d683abab3120935f1f4cef4c5696611369fcaf972d359659b671ba0ff4861550c25502cf16ec7124289f179bcc1ece7b39f5dc72c4eb SHA512 ee61a219cb0be58be48e458fd9955dd97ee6aa2358c31951b42a4168285969f8b31e507ff00b73b43484649c5a2225e6af34d24e6e4f8c078f075de4dbc4b2e4
+EBUILD gentoo-syntax-20210716.ebuild 1245 BLAKE2B 4de7b82e15d0e8e0716fa3b419297d3ce15bbe12d7fc8007e231bc09cd3d9236af4c5d08e7c6dec0c1058150eec401c37a24d3b5bade0319947617db9d358bb6 SHA512 9a14cb1d43d22cde53c0f7c9598bfdbb2cd1f0417bc69b604823f595b6f1a59a95aeb47cd61a68707abe8412a2ca44d71a67a51c731d7e083b2f4cab299e6584
EBUILD gentoo-syntax-99999999.ebuild 1087 BLAKE2B 9b7c64f1ec0215aa53e39c0c4db8352c47b19ee89a894dc95ef4a867415337ff901befaadf2ce468804e4167410c1d034002ca476c90925096875b3dc27b8868 SHA512 5f0e991bcc491e807ea86d89c47dcc8d6879c35d0f42d191a4e2cd4d40f117022e70cfb92503184e638273daed9780363066d07667c138592be1e1b6f4435b99
MISC metadata.xml 585 BLAKE2B 7f904a47ab12627ae911fa96328c50af2cb16b785fa0b60cace8a586b17de344625b749b52ef6b89b4751aba74bc25339b3e6c9105ee47d15b5c6539b5d902ee SHA512 dfed3c4c2b3697b00896591dc4b23eb6433ce77b4aaaab05119ca0b11e355e321b2cf5f0ab5e0b2dd075abd1a266908e07b80846a11d50f17155d7ab35e6c742
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20210716.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20210716.ebuild
new file mode 100644
index 000000000000..72f25ef766b6
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20210716.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}
diff --git a/app-vim/salt-vim/Manifest b/app-vim/salt-vim/Manifest
index 7fd5ffd87842..b8bb9255dc2d 100644
--- a/app-vim/salt-vim/Manifest
+++ b/app-vim/salt-vim/Manifest
@@ -1,3 +1,3 @@
DIST salt-vim-20151119.tar.gz 4009 BLAKE2B fc11e5b7ab54283c1e595b4dae608697504f5673862fb627455ae29768b2948a3fcb81117ae6f9bea460412927b22d95d8ea071013bc41848a624c035a7d5609 SHA512 4267263836c986c33d19739afc8ff710234f3519b3f2ed5f4ddd1a929691e02563dd87a0d722d098a2038610b3b0d5021d00497b25cc00bd6ec6b6fcfedb9105
-EBUILD salt-vim-20151119.ebuild 563 BLAKE2B ea04c3aabe20d770ff08373d5ddd182387309ae009fb77513d4cc40fdc35b67ce55195bd442a3ff7fb688bc054bd07c899dcef6a51e66518204ef8c9a6c6636b SHA512 ec97ae6cd285aebb70d0232734f5ca34da8f13ef282305a97101ef88eaeede21333ccc485e7a6608cda90a879e8990aacfa7becfd56138db700cead430affb0f
+EBUILD salt-vim-20151119.ebuild 570 BLAKE2B cbc40f8f40bd3b7642f4b0b67e789b67cef717d605b2c2844507960a6b3954e06ae2b3ec85a6bd8ba3585b51bf2d92b083e93c3bcfde2342c03fecca6a21eba4 SHA512 ee595c240e15fe502c9635b0bb15a23c6e4bdadaf2270305b2c02f68ca311b6d9c35d2ff762624e316f6498564deecf8dc287358057819a83681b694a25fe6b2
MISC metadata.xml 442 BLAKE2B 83791e635a49aeda35b19391dbc091d91440f5e319e00397798e1b708f876546ffc729353472e07f56935b735a449c22cea49d94a481baea008b94971f917084 SHA512 070c99868fe3b9929748607fd0fb8d93860cce5eacbc84603c1dae349552908f9b18b61cf3814cb3042289aedc8e41c36c86ce4cdd18c9755fac2b11fb7dd880
diff --git a/app-vim/salt-vim/salt-vim-20151119.ebuild b/app-vim/salt-vim/salt-vim-20151119.ebuild
index b5584b455255..c094923f3dc7 100644
--- a/app-vim/salt-vim/salt-vim-20151119.ebuild
+++ b/app-vim/salt-vim/salt-vim-20151119.ebuild
@@ -11,7 +11,7 @@ DESCRIPTION="Vim files for working on Salt files"
HOMEPAGE="https://github.com/saltstack/salt-vim"
SRC_URI="https://github.com/saltstack/${PN}/archive/${SALT_VIM_HASH}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
-KEYWORDS="amd64 ~arm x86"
+KEYWORDS="amd64 ~arm ~arm64 x86"
RDEPEND="!<=app-admin/salt-2015.5.6
!~app-admin/salt-2015.8.0