summaryrefslogtreecommitdiff
path: root/app-vim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-02 15:47:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-02 15:47:42 +0000
commit48ee15e0d6219049c34310890504cad652b756ea (patch)
tree18384522dd86149666e4e97758cf77e4151f694f /app-vim
parenta0c5e9067531830baf9160de325fe77145f02987 (diff)
gentoo auto-resync : 02:11:2023 - 15:47:42
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/Manifest.gzbin31619 -> 31629 bytes
-rw-r--r--app-vim/gentoo-syntax/Manifest2
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-12.ebuild42
3 files changed, 44 insertions, 0 deletions
diff --git a/app-vim/Manifest.gz b/app-vim/Manifest.gz
index 2eef7f93d0da..abe9fa5dbb41 100644
--- a/app-vim/Manifest.gz
+++ b/app-vim/Manifest.gz
Binary files differ
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 3be937a5f7a9..18b0dad00735 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,4 +1,6 @@
DIST gentoo-syntax-11.tar.bz2 20986 BLAKE2B dd4d4d3a65480a4600d9c1372fdb1db40c07d3a954232513a535cd9e7d59e5e89f185e32aa7bfe38909e1ef4b0e2639136478ba9ab7eb6ceedd9fdb459b08da2 SHA512 9c74b38880429e2e980e8f44b51ed5bc3bb1431d8429a7ac66574556e3ca01e909c445585da9152d78e38d23cc9a4c100bb81f56ea8c0b63291b8df0dca7b886
+DIST gentoo-syntax-12.tar.bz2 21022 BLAKE2B 758993282ccc26384bb1fc761f2a07059d5e2e7038f56d48ec19ac82ddecb7cd1601fbdd4221e6b41b43281195d862c93d98c12c47d2d43f4a6cbb4784ae6b46 SHA512 07bc7102b3f687c53d8e46c5ca91c1d605239490f160c6db11c6d17ae95b94d34e9ac654b3c9935099382f39ba8b92ea373b09f86fc6452840d12f135820b2b3
EBUILD gentoo-syntax-11.ebuild 1200 BLAKE2B bc3c6960d94b3f50e52dcfc8de276c6070745233ec7a1519d2bc01930ef03b7d67efa8335fdba040922bfc48660498f29ca9906f1a96d4d1f58668159692b6b0 SHA512 430dcdf9a519ff4550200f81f588b8367a792eaea86bada841ffd3c9b2dd6ec30c243e8f95b02edc6002f1320531e7f80083e1421dc94c9126f7eeb33b14d4c9
+EBUILD gentoo-syntax-12.ebuild 1208 BLAKE2B 5f6ba36cc2b34fe5bbe101e0b00de2fa2d38b9cd6e66cd12b6b580f7b1ce18e62a08167b549d02bc4c175d9ee523f83bf7a760a94c171370d30a8eedd40ce7c2 SHA512 e965b2e3da9ee8ddd92f0d5d214d60c7b244dc0a0b3de9d9497a558de7a2ddfef39f948079512191754173f073c0824e2086be7900df8d16c160aacb3ee6bf58
EBUILD gentoo-syntax-9999.ebuild 1084 BLAKE2B 5e2edf4d1eddb74486a7ef6c8025a2874591d90d0ff1bb5077781f3c66d43bfbebf0421561a7c730e1baff613776c0962c907aec502a6627d8361034b28e1bf3 SHA512 4af267e60fcf53b736c41232cb44241d2181afd3b38516a6e4a7a7b7ea83db10a4fec7272b362847bf773296f348a2b08503ce757886a14ff08a215ba5341194
MISC metadata.xml 646 BLAKE2B d33ab1ce3b852316a114a27c7768310491f51669a44a183c5b2fe639a0d2e65439759de9a83cb019467ef5d206470454bfe1939906d32c1a7fe6ebad0458e14b SHA512 a75bc08e066deac74dc6a8a9927e232be4facc31e0810121480c07e75549de2cbc974eff9f71f2c59fb17f0739bd0cd9cede9a048af4715047a796b6a5afea7d
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-12.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-12.ebuild
new file mode 100644
index 000000000000..8465cb7009c6
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-12.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}