summaryrefslogtreecommitdiff
path: root/app-vim/xsl-syntax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
commitefca79f216bfeffd55e7731fbf24126d093e1084 (patch)
treef19ba31d8686b3de4192db3e4c4dc9f3d9af54b5 /app-vim/xsl-syntax
parentea7f3f690b55cdfa8b2d350b03c1dfc0c8357a51 (diff)
gentoo auto-resync : 15:09:2023 - 04:49:10
Diffstat (limited to 'app-vim/xsl-syntax')
-rw-r--r--app-vim/xsl-syntax/Manifest1
-rw-r--r--app-vim/xsl-syntax/xsl-syntax-0.3.11-r3.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/app-vim/xsl-syntax/Manifest b/app-vim/xsl-syntax/Manifest
index 4e7efa8896ff..ace84f20d038 100644
--- a/app-vim/xsl-syntax/Manifest
+++ b/app-vim/xsl-syntax/Manifest
@@ -1,3 +1,4 @@
DIST xsl-syntax-0.3.11.tar.bz2 5770 BLAKE2B d7d06bf7e2537c8c6c1419f557e4c29042a1af6dd31850c28feccbd342a1beb60dded565f48b715d021ebe3279e0d4a75daa3063e7e8347a1977f97947a0a92a SHA512 e09f0f6ebe023a681560a12e919c9573abc2bf0f1a6fe1bda233ca296fa4fa81bead99aeb7eafb387f04e199f7601d8ce6593c767be1b3e94ff73135ea0f4361
EBUILD xsl-syntax-0.3.11-r2.ebuild 564 BLAKE2B b25dd8ec8b9b0bc662594c5dcbeb014066b50236151fd5848fd78923ecf5138d2e6b0db0ff3f53c770b113d66f45f0ffa8d9b234215d06e97899d6b5085ca3c2 SHA512 4a0a7a429ed815f1b3bba6147cc50b2c3915b8fce2a5d2a6fcc33573871115e597735439ba735c17314dab84d40a63596113cc8fb628ecadbf8ec1b295033e1e
+EBUILD xsl-syntax-0.3.11-r3.ebuild 563 BLAKE2B 7c09dbd0d00334473ac05145c28848da8334532d392d6a65c0bf8569d2f1d1d77d74ceaac7479b6b57c003e2d1000eea7f843d28780355fbf429a953223e3748 SHA512 fc2d8044d20f6d7c2e6e553610dfee9a948885938dfe66f3d39b8a17761a38ee8611d63ef991649c2ef5e131a4dace9b70778340fc863ddb02b508ab4a0f8187
MISC metadata.xml 250 BLAKE2B 159edb6cbbe3884fd7b328cba2125da0a51b5c0be964e60b708efe1bd040a41abdf16f8dbcfaecb9e6e1073528ac99195a08d7045d433414ec2ba1c94d582761 SHA512 6c29f24b33b8829463103cee99e2cf65cf550aa1d6c60c5a746ca2947a97a052969c8dfb9d12ae8114db0971626f9246cb9e4808d951eeae78321325da1ac32a
diff --git a/app-vim/xsl-syntax/xsl-syntax-0.3.11-r3.ebuild b/app-vim/xsl-syntax/xsl-syntax-0.3.11-r3.ebuild
new file mode 100644
index 000000000000..fb380c5d310a
--- /dev/null
+++ b/app-vim/xsl-syntax/xsl-syntax-0.3.11-r3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Syntax for XSLT (with HTML and others)"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=257"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+VIM_PLUGIN_HELPURI="https://www.vim.org/scripts/script.php?script_id=257"
+
+src_prepare() {
+ default
+ # hi link is evil. See bug #101787, bug #101804.
+ sed -i -e 's,^hi link,hi def link,' syntax/xsl.vim || die "sed failed"
+}