summaryrefslogtreecommitdiff
path: root/app-vim/webapi/webapi-0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
commitcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (patch)
tree047fc92023c520d07f13ec5ac96e094d1b312a7a /app-vim/webapi/webapi-0.3.ebuild
parent7b9f15840068dfaeea5684f8a1af1fe460dfa14c (diff)
gentoo resync : 09.06.2018
Diffstat (limited to 'app-vim/webapi/webapi-0.3.ebuild')
-rw-r--r--app-vim/webapi/webapi-0.3.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-vim/webapi/webapi-0.3.ebuild b/app-vim/webapi/webapi-0.3.ebuild
new file mode 100644
index 000000000000..7a9673e4e753
--- /dev/null
+++ b/app-vim/webapi/webapi-0.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: interface to Web APIs"
+HOMEPAGE="https://github.com/mattn/webapi-vim"
+SRC_URI="https://github.com/mattn/${PN}-vim/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+
+RDEPEND="net-misc/curl"
+
+S="${WORKDIR}/${PN}-vim-${PV}"
+
+src_prepare() {
+ default
+ rm -v Makefile || die
+}