summaryrefslogtreecommitdiff
path: root/app-vim/vspec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-vim/vspec
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-vim/vspec')
-rw-r--r--app-vim/vspec/Manifest3
-rw-r--r--app-vim/vspec/metadata.xml14
-rw-r--r--app-vim/vspec/vspec-1.9.2.ebuild52
3 files changed, 69 insertions, 0 deletions
diff --git a/app-vim/vspec/Manifest b/app-vim/vspec/Manifest
new file mode 100644
index 000000000000..f31ef8cb7987
--- /dev/null
+++ b/app-vim/vspec/Manifest
@@ -0,0 +1,3 @@
+DIST vspec-1.9.2.tar.gz 28882 BLAKE2B 016b91e2eb9ef5b6d8ebf563ddd620ce9e57dc4a9d013a67b3d5cf644325c49f02aaef8b3a114b6802494ca026989ff56ab1f0cb5e398f6cc9eb91fee96797ea SHA512 0c453743f73cfc5990fcb7222cc6fc1b96b93b15b4ef701562f84ae8ef2961c0e2e256f32a400218518463b932a3efdba33e3ca0b418f3ac6969ab38aeaf348c
+EBUILD vspec-1.9.2.ebuild 1199 BLAKE2B 6dea3b958451acf85108d03653ca5429cecfc95cdb9bf30c205340b462b70a33382e5c5bae388bb7d91d67a2e3e11782a408cbdf5c54b7ada4ed97f5d4a0b01e SHA512 5666820d62b56bb4af71e5cdcbd613fdbe661442e095624fb841db97438db6a89c297be5453c8457d8d4474f4eef326b498e6b52ce7217210cc368faa01ec124
+MISC metadata.xml 397 BLAKE2B 26d086c79b35cd480bc59bcba74bf3f0df7310fda8150f0933e2dee235a66ee59f8145750a2523f8e84e7cd52065145143afc6296b019b8a2b46b23af1b772b0 SHA512 35626f98c412577f37a9e85f824fbcc2fd57f0b7d6735feb0e6212192641f4fe3f873aeb99243bd5d767e471dde1b5868256d6626574aa74551dd712a641f07a
diff --git a/app-vim/vspec/metadata.xml b/app-vim/vspec/metadata.xml
new file mode 100644
index 000000000000..c8d770d94a01
--- /dev/null
+++ b/app-vim/vspec/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>cyber+gentoo@sysrq.in</email>
+ <name>Anna</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kana/vim-vspec</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vspec/vspec-1.9.2.ebuild b/app-vim/vspec/vspec-1.9.2.ebuild
new file mode 100644
index 000000000000..5dcd6e400cb4
--- /dev/null
+++ b/app-vim/vspec/vspec-1.9.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo vim-plugin
+
+DESCRIPTION="A testing framework for Vim script"
+HOMEPAGE="
+ https://www.vim.org/scripts/script.php?script_id=3012
+ https://github.com/kana/vim-vspec
+"
+SRC_URI="https://github.com/kana/vim-${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/vim-${P}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-lang/perl:*"
+BDEPEND="test? ( ${RDEPEND} )"
+
+VIM_PLUGIN_HELPFILES="vspec.txt"
+
+# Uncomment on the next release
+#DOCS=( {README,TUTORIAL_CI}.md )
+
+src_prepare() {
+ vim-plugin_src_prepare
+
+ # remove failing tests
+ rm t/{indent,syntax}.vim || die
+}
+
+src_test() {
+ export LC_ALL=C
+ edo ./bin/prove-vspec
+}
+
+src_install() {
+ # fix paths for the binary to be installed; don't do it in src_prepare
+ # as it will make the tests fail
+ sed "s|\$0|${EPREFIX}/usr/share/vim/vimfiles/bin/vspec|g" \
+ -i bin/vspec || die
+
+ vim-plugin_src_install bin
+
+ fperms +x /usr/share/vim/vimfiles/bin/{vspec,prove-vspec}
+ dosym -r {/usr/share/vim/vimfiles,/usr}/bin/vspec
+ dosym -r {/usr/share/vim/vimfiles,/usr}/bin/prove-vspec
+}