summaryrefslogtreecommitdiff
path: root/app-vim/vimtex/vimtex-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-25 19:22:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-25 19:22:13 +0100
commit6bd95d1f6320b8666a31ec949183aaa3088aa16f (patch)
treeff9f0cde8bfba5191f96c690c269c814c134a51e /app-vim/vimtex/vimtex-99999999.ebuild
parentb279bbe94522565b8feb19b8e5f377d3ea76f157 (diff)
gentoo resync : 25.03.2018
Diffstat (limited to 'app-vim/vimtex/vimtex-99999999.ebuild')
-rw-r--r--app-vim/vimtex/vimtex-99999999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-vim/vimtex/vimtex-99999999.ebuild b/app-vim/vimtex/vimtex-99999999.ebuild
new file mode 100644
index 000000000000..d4031034c014
--- /dev/null
+++ b/app-vim/vimtex/vimtex-99999999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/lervag/vimtex.git"
+ inherit git-r3
+else
+ inherit vcs-snapshot
+ COMMIT_HASH="17d809706edcb277f1ee7fa5e33aff3619926fe4"
+ SRC_URI="https://github.com/lervag/vimtex/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: a modern vim plugin for editing LaTeX files"
+HOMEPAGE="https://github.com/lervag/vimtex"
+LICENSE="MIT"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="
+ !app-vim/vim-latex
+ !app-vim/automatictexplugin
+ virtual/latex-base
+ dev-tex/latexmk
+"
+
+src_prepare() {
+ default
+
+ # remove unwanted files
+ rm -r *.md media test || die
+}