summaryrefslogtreecommitdiff
path: root/app-vim/vimpython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/vimpython
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/vimpython')
-rw-r--r--app-vim/vimpython/Manifest4
-rw-r--r--app-vim/vimpython/metadata.xml8
-rw-r--r--app-vim/vimpython/vimpython-1.13-r1.ebuild14
-rw-r--r--app-vim/vimpython/vimpython-1.13-r2.ebuild18
4 files changed, 44 insertions, 0 deletions
diff --git a/app-vim/vimpython/Manifest b/app-vim/vimpython/Manifest
new file mode 100644
index 000000000000..e573857c719c
--- /dev/null
+++ b/app-vim/vimpython/Manifest
@@ -0,0 +1,4 @@
+DIST vimpython-1.13.tar.bz2 4270 BLAKE2B 7973aea8ea397f3f2edcf8a2845ab47cad3015925dd9e42e37a7ada47f25073b68d6d8f8c378a86d90e39c0aae63aba784753679b4d04a5aad268db157400ae2 SHA512 467217ad160f02d3ecdc8c43e35966e496e6c5f99bef115bd4905795c0fd5b8f68f68bc8edd64ca1dbb1c6fbc088ef6ae996f524f0343943702f2a92dcc144ce
+EBUILD vimpython-1.13-r1.ebuild 385 BLAKE2B fb67a5dc1f6072159f92d02dbbc205e8869ddbc8b62669098cae1533f7b7fe5fd80e2783690e2b504ea4a5cf390d1a3a7df4a9d98ed9a97a47b42ae749f0c15a SHA512 5427cad779f09e12eb12510db56ebd6eee635127725120a0a95276de44121a9d757223eff8e2ec52b7ef44b64892db8ed60628c00acd31e52c3309c6d5cdbfa4
+EBUILD vimpython-1.13-r2.ebuild 489 BLAKE2B 6785bc25b55ad9b91d3e4d460b9ddbcba703dca50fc26ebab397293c71700edd2bf998ccba4b123547f5cf953f22881e4b55c04cb6fd06b0690d1926b9d07424 SHA512 af5170c50b4e02820bf9bf2562dca919d9066f73a19873a79359166dcb5fcde97cf76a78d7c192c24f6147e6fde1bebfecca83375e6584563ee1e73995131a16
+MISC metadata.xml 249 BLAKE2B 7ae6eac3ca23edbcbaa6aee682bb4aec155e3166f169eef8e4400e59fa56113ecc3593680d55cc57f08a4a718963dd3d0bb804bd1e8771ed60a4bebaae9db281 SHA512 4051dd059d975d2e1799125f7defbf5a62a168241d8b83d83710592efd60808800951c4fd6da1294044d7e7ec6b757b8d50593fd076696f826dec761e99645c7
diff --git a/app-vim/vimpython/metadata.xml b/app-vim/vimpython/metadata.xml
new file mode 100644
index 000000000000..5c000c763084
--- /dev/null
+++ b/app-vim/vimpython/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/vimpython/vimpython-1.13-r1.ebuild b/app-vim/vimpython/vimpython-1.13-r1.ebuild
new file mode 100644
index 000000000000..1801d3944d58
--- /dev/null
+++ b/app-vim/vimpython/vimpython-1.13-r1.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: A set of menus/shortcuts to work with Python files"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=30"
+LICENSE="vim"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-lang/python:*"
diff --git a/app-vim/vimpython/vimpython-1.13-r2.ebuild b/app-vim/vimpython/vimpython-1.13-r2.ebuild
new file mode 100644
index 000000000000..08a1107fa94f
--- /dev/null
+++ b/app-vim/vimpython/vimpython-1.13-r2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="vim plugin: A set of menus/shortcuts to work with Python files"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=30"
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${PYTHON_DEPS}"