summaryrefslogtreecommitdiff
path: root/app-vim/vimpython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /app-vim/vimpython
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'app-vim/vimpython')
-rw-r--r--app-vim/vimpython/Manifest1
-rw-r--r--app-vim/vimpython/vimpython-1.13-r3.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/app-vim/vimpython/Manifest b/app-vim/vimpython/Manifest
index 948aa273a429..ad0e79d0f75b 100644
--- a/app-vim/vimpython/Manifest
+++ b/app-vim/vimpython/Manifest
@@ -1,3 +1,4 @@
DIST vimpython-1.13.tar.bz2 4270 BLAKE2B 7973aea8ea397f3f2edcf8a2845ab47cad3015925dd9e42e37a7ada47f25073b68d6d8f8c378a86d90e39c0aae63aba784753679b4d04a5aad268db157400ae2 SHA512 467217ad160f02d3ecdc8c43e35966e496e6c5f99bef115bd4905795c0fd5b8f68f68bc8edd64ca1dbb1c6fbc088ef6ae996f524f0343943702f2a92dcc144ce
EBUILD vimpython-1.13-r2.ebuild 476 BLAKE2B c0c1efbdb02121f9168a1e6e3d025048d9c680325b2e33b71141568fb874409c915a179b16c211b86017e7429b2939b861d7f2d0eddcbfb43bbf25e1bdc68d96 SHA512 e915c6833d83bf26362304294ac71ac1983ae3e565efdb116b6dd8706dd30c41d62e89ad15ae2fb1413c945c27dc51cce673988657898fce7b321d0f2b922b9b
+EBUILD vimpython-1.13-r3.ebuild 482 BLAKE2B d19134f78f6be51ab66e9963e8ea43e3856b18e4cd074a729a099e82285184e0d30454956b6321d63aa1fd95775bbc5d90ff00137479e71eaaf01218445d4bba SHA512 28ccb1feee5c79bb914e0bea7b96aa487b91a5c3288730d6af8e234b00de342e44feb1df6b2231c4e33fd65d399f3e35646cf78ff1a89ad054332a363937cda8
MISC metadata.xml 249 BLAKE2B 7ae6eac3ca23edbcbaa6aee682bb4aec155e3166f169eef8e4400e59fa56113ecc3593680d55cc57f08a4a718963dd3d0bb804bd1e8771ed60a4bebaae9db281 SHA512 4051dd059d975d2e1799125f7defbf5a62a168241d8b83d83710592efd60808800951c4fd6da1294044d7e7ec6b757b8d50593fd076696f826dec761e99645c7
diff --git a/app-vim/vimpython/vimpython-1.13-r3.ebuild b/app-vim/vimpython/vimpython-1.13-r3.ebuild
new file mode 100644
index 000000000000..9f704f796ebc
--- /dev/null
+++ b/app-vim/vimpython/vimpython-1.13-r3.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="vim plugin: A set of menus/shortcuts to work with Python files"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=30"
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${PYTHON_DEPS}"