summaryrefslogtreecommitdiff
path: root/app-vim/vimpress/vimpress-2.1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/vimpress/vimpress-2.1.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/vimpress/vimpress-2.1.5.ebuild')
-rw-r--r--app-vim/vimpress/vimpress-2.1.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-vim/vimpress/vimpress-2.1.5.ebuild b/app-vim/vimpress/vimpress-2.1.5.ebuild
new file mode 100644
index 000000000000..0153e0641076
--- /dev/null
+++ b/app-vim/vimpress/vimpress-2.1.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit vim-plugin
+
+MY_PN="VimRepress"
+DESCRIPTION="vim plugin: manage wordpress blogs from vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3510"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ || ( dev-lang/python:2.7 dev-lang/python:2.6 )
+ dev-python/markdown"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ rm README || die
+}