summaryrefslogtreecommitdiff
path: root/app-vim/vimoutliner/vimoutliner-0.3.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/vimoutliner/vimoutliner-0.3.6-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/vimoutliner/vimoutliner-0.3.6-r1.ebuild')
-rw-r--r--app-vim/vimoutliner/vimoutliner-0.3.6-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-vim/vimoutliner/vimoutliner-0.3.6-r1.ebuild b/app-vim/vimoutliner/vimoutliner-0.3.6-r1.ebuild
new file mode 100644
index 000000000000..d639684e4902
--- /dev/null
+++ b/app-vim/vimoutliner/vimoutliner-0.3.6-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="vim plugin: easy and fast outlining"
+HOMEPAGE="https://github.com/vimoutliner/vimoutliner"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.zip -> ${P}.zip"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+VIM_PLUGIN_HELPFILES="vimoutliner"
+VIM_PLUGIN_MESSAGES="filetype"
+
+PATCHES=( "${FILESDIR}/${P}-fix-shebangs.patch" )
+
+RDEPEND="dev-python/autopep8"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ sed -i -e '/^if exists/,/endif/d' ftdetect/vo_base.vim || die
+ sed -i -e 's/g:vo_modules2load/g:vo_modules_load/' vimoutliner/vimoutlinerrc || die
+ rm -v install.sh || die
+ find "${S}" -type f -exec chmod a+r {} \; || die
+}
+
+src_compile() {
+ local pyscript _pyscript
+ for pyscript in $(find "${S}" -type f -name \*.py); do
+ _pyscript=$(basename "${pyscript}")
+ einfo "Processing ${_pyscript}"
+ sed -i -e 's#[ \t]*$##g;' "${pyscript}" || die
+ 2to3 --no-diffs -w -n "${pyscript}" 2> /dev/null || die
+ autopep8 -i "${pyscript}" || die
+ python_fix_shebang -q "${pyscript}" || die
+ eend $?
+ done
+}