summaryrefslogtreecommitdiff
path: root/app-vim/vimagit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/vimagit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/vimagit')
-rw-r--r--app-vim/vimagit/Manifest6
-rw-r--r--app-vim/vimagit/metadata.xml11
-rw-r--r--app-vim/vimagit/vimagit-1.7.1.ebuild20
-rw-r--r--app-vim/vimagit/vimagit-1.7.2.ebuild25
-rw-r--r--app-vim/vimagit/vimagit-9999.ebuild25
5 files changed, 87 insertions, 0 deletions
diff --git a/app-vim/vimagit/Manifest b/app-vim/vimagit/Manifest
new file mode 100644
index 000000000000..1e428795d22c
--- /dev/null
+++ b/app-vim/vimagit/Manifest
@@ -0,0 +1,6 @@
+DIST vimagit-1.7.1.tar.gz 35302 BLAKE2B e8e46f399ef700d971e61a233af41a3735faf29fe95baa53b6e0888c0b708a1bfcee051bb9afc90348585f3cb3cf9278fe47a1ed17096d956ccecbc45398c4bc SHA512 8ce2959c135da90b880ccdcd66e71661c7908f250d47a24ede025762a6e9422cebcf8fd516bf99e475605f4278e232713c66293781ceb95f47a22031e9260a71
+DIST vimagit-1.7.2.tar.gz 37398 BLAKE2B c7e0a82ebb7a1d1ae5e2c5aa0c6c8f8a2b45fa65a193b6dcd8a97822d4ecb99ba60dd86156390db4de0fb0ce39883e67a1b17157d8c259a0ad6559a52cefbeb2 SHA512 8b825da4b411732db022b1a3f25f6f779ba5e58df5ca4d404e985b16a4811f911c626674f1a7f4a285d78369f4c7ad3a33b7ffa2b50f1a4a94372a3c5fb29a15
+EBUILD vimagit-1.7.1.ebuild 528 BLAKE2B ff657862f6b37886aa82517fc7425c1b4099ab6e7da1f06fc4bd9078e0732a5887a10a51f993d163d090c9a406d9597407d216598a055bb4571a817d63f10838 SHA512 c40090e5f0c543911e41d4edb33be1775806fb67ede5d32690c5513539f9861d30a8013bb2ae378ef38c4020daa7cb76d275648ecbf43721484005fbfbdec382
+EBUILD vimagit-1.7.2.ebuild 579 BLAKE2B 414fd63cd4037e489408da8cdcca4b93aeeef0a6a588366adb000cdcdd54fbe649f73ff0649409fdc74f1781f5fc6fea4ce837e15d1703b155f096d9fed15400 SHA512 52896f63772d399f5e6da40c3e622c6b87e7a8e7c65978883b60715dd4882d5aec2450bf3c766cc23de6851750030dd8bf3b26867bc963aafe1c21c59c9f6a0c
+EBUILD vimagit-9999.ebuild 579 BLAKE2B 414fd63cd4037e489408da8cdcca4b93aeeef0a6a588366adb000cdcdd54fbe649f73ff0649409fdc74f1781f5fc6fea4ce837e15d1703b155f096d9fed15400 SHA512 52896f63772d399f5e6da40c3e622c6b87e7a8e7c65978883b60715dd4882d5aec2450bf3c766cc23de6851750030dd8bf3b26867bc963aafe1c21c59c9f6a0c
+MISC metadata.xml 340 BLAKE2B d17f938b8d8441774f98d8780bb3cd59d2b716a7f74533a16c54f7cf9c10b565bd0f82d513b48ffa7e10e15c8456bcaa8b51cc91b246cf5fff2e691424637be0 SHA512 f9c0871441cc968a62ebc15e75f7f3977a827b7c303b3cf721cadb5030deb9af5356667e149bdd7fb02af63398fe6226e24bc11a770e3c4d6a03c5c9d241d60b
diff --git a/app-vim/vimagit/metadata.xml b/app-vim/vimagit/metadata.xml
new file mode 100644
index 000000000000..5b153f66c473
--- /dev/null
+++ b/app-vim/vimagit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jreybert/vimagit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vimagit/vimagit-1.7.1.ebuild b/app-vim/vimagit/vimagit-1.7.1.ebuild
new file mode 100644
index 000000000000..1583759b0cc2
--- /dev/null
+++ b/app-vim/vimagit/vimagit-1.7.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jreybert/vimagit.git"
+else
+ SRC_URI="https://github.com/jreybert/vimagit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: ease your git workflow within vim"
+HOMEPAGE="https://github.com/jreybert/vimagit"
+LICENSE="vim"
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="dev-vcs/git"
diff --git a/app-vim/vimagit/vimagit-1.7.2.ebuild b/app-vim/vimagit/vimagit-1.7.2.ebuild
new file mode 100644
index 000000000000..5e291f76fe70
--- /dev/null
+++ b/app-vim/vimagit/vimagit-1.7.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jreybert/vimagit.git"
+else
+ SRC_URI="https://github.com/jreybert/vimagit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: ease your git workflow within vim"
+HOMEPAGE="https://github.com/jreybert/vimagit"
+LICENSE="vim"
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="dev-vcs/git"
+
+src_prepare() {
+ rm _config.yml || die
+ default
+}
diff --git a/app-vim/vimagit/vimagit-9999.ebuild b/app-vim/vimagit/vimagit-9999.ebuild
new file mode 100644
index 000000000000..5e291f76fe70
--- /dev/null
+++ b/app-vim/vimagit/vimagit-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jreybert/vimagit.git"
+else
+ SRC_URI="https://github.com/jreybert/vimagit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: ease your git workflow within vim"
+HOMEPAGE="https://github.com/jreybert/vimagit"
+LICENSE="vim"
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="dev-vcs/git"
+
+src_prepare() {
+ rm _config.yml || die
+ default
+}