summaryrefslogtreecommitdiff
path: root/app-vim/vimagit/vimagit-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/vimagit/vimagit-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/vimagit/vimagit-9999.ebuild')
-rw-r--r--app-vim/vimagit/vimagit-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/vimagit/vimagit-9999.ebuild b/app-vim/vimagit/vimagit-9999.ebuild
new file mode 100644
index 000000000000..5e291f76fe70
--- /dev/null
+++ b/app-vim/vimagit/vimagit-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jreybert/vimagit.git"
+else
+ SRC_URI="https://github.com/jreybert/vimagit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: ease your git workflow within vim"
+HOMEPAGE="https://github.com/jreybert/vimagit"
+LICENSE="vim"
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="dev-vcs/git"
+
+src_prepare() {
+ rm _config.yml || die
+ default
+}