summaryrefslogtreecommitdiff
path: root/app-vim/vim2hs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-10 00:43:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-10 00:43:02 +0000
commita5332b59346f7cbf0fdbd148b54aa8a84aaf8190 (patch)
treee6d8d3589fcd01fbc3f1286185639163daa81424 /app-vim/vim2hs
parentfceeaf01a28ee71065cf3798b70b77d3bc4ef199 (diff)
gentoo resync : 10.11.2017
Diffstat (limited to 'app-vim/vim2hs')
-rw-r--r--app-vim/vim2hs/Manifest3
-rw-r--r--app-vim/vim2hs/metadata.xml11
-rw-r--r--app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild31
3 files changed, 45 insertions, 0 deletions
diff --git a/app-vim/vim2hs/Manifest b/app-vim/vim2hs/Manifest
new file mode 100644
index 000000000000..659697593080
--- /dev/null
+++ b/app-vim/vim2hs/Manifest
@@ -0,0 +1,3 @@
+DIST vim2hs-0.1_p20171106.tar.gz 259627 SHA256 7190ad8b7f205331d6485b584acfdca6c0b45aed4e5242e482110d17871bc728 SHA512 835ea1344f055af06843a327bf7294ae9fe0e735455b3c21d4fba56eab75f19b578ff8cd962f6527efee0e0f89084c9c2cd86d3944e0ac35b89b33a6047df4a0 WHIRLPOOL 40caa6f1fccd6b344e8b808c99387c4ecceec935fce219ba42587e59b9a390fc23e99c8bbbf7e7933a3c95975dc773c0be5363aee6ebaf6e4ac1b3131c891711
+EBUILD vim2hs-0.1_p20171106.ebuild 682 SHA256 d67d7a2dce99438b1b92dbee79c4260ac6410fbede75ca4c1db79e4cdafc6bd1 SHA512 9f241d711331ebad1a1c590ff93932ee7abd52176bc0075bb60aadeaad9ec40be609fb1e752d7a9fc9b64c066b35a1c4468b46992052dc33b5c4476dbccf4bdf WHIRLPOOL 9da7cb4629b953155c54d4f8fcb1ed784c6d3c9fd222f3b6a0eb15b5d8a1346eda3b79524ddc3b386cd979d473b48f5193e396371f17c33649726f12102665af
+MISC metadata.xml 324 SHA256 8750a8930ef38315645edadc6e67dae9f36f794eeeaead9ddfe000b2f52b144f SHA512 6e87e1076ba13e49fa20313e9761cee9628350e718ab871bfd2bab0409f69dc9afa48d7d530540be8af5d7b10d2c7a14269fc70839ae63351a2a3d3f82e1481c WHIRLPOOL 968bb1993b8b2d94b927129a276996aae2eaa5c2c2528e03bd17bae56ef7706fa8926044367b2a2c618e24fe608545fff4dfece8011fe93d69c479093b713e7d
diff --git a/app-vim/vim2hs/metadata.xml b/app-vim/vim2hs/metadata.xml
new file mode 100644
index 000000000000..cf984477fc49
--- /dev/null
+++ b/app-vim/vim2hs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">dag/vim2hs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild b/app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild
new file mode 100644
index 000000000000..4d8504e4b3a0
--- /dev/null
+++ b/app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+# Commit Date: 16 Apr 2014
+COMMIT="f2afd55704bfe0a2d66e6b270d247e9b8a7b1664"
+
+DESCRIPTION="vim plugin: collection of vimscripts for Haskell development"
+HOMEPAGE="https://github.com/dag/vim2hs"
+SRC_URI="https://github.com/dag/vim2hs/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/ghc"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_compile() { :; }
+
+src_install() {
+ # We want a stripped-down version of these.
+ local f
+ for f in screenshots/*; do
+ bzip2 -9 "${f}" || die
+ done
+ vim-plugin_src_install
+}