summaryrefslogtreecommitdiff
path: root/app-vim/vim2hs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/vim2hs
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/vim2hs')
-rw-r--r--app-vim/vim2hs/Manifest3
-rw-r--r--app-vim/vim2hs/metadata.xml11
-rw-r--r--app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild29
3 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/vim2hs/Manifest b/app-vim/vim2hs/Manifest
new file mode 100644
index 000000000000..2be313a067d4
--- /dev/null
+++ b/app-vim/vim2hs/Manifest
@@ -0,0 +1,3 @@
+DIST vim2hs-0.1_p20171106.tar.gz 259627 BLAKE2B 48a6bd773709ea1df0efcd3fe580cec353ef3c3ae7aadd4693313c3bc294238d5f73ccc84c32f75edd3e708a2be74c22efbe077d448b1dd3102e89c0ded6efe6 SHA512 835ea1344f055af06843a327bf7294ae9fe0e735455b3c21d4fba56eab75f19b578ff8cd962f6527efee0e0f89084c9c2cd86d3944e0ac35b89b33a6047df4a0
+EBUILD vim2hs-0.1_p20171106.ebuild 663 BLAKE2B 6af8233fead7dacf920a4578dcfb4b26ff0deb7ace8f833c3da4d9b03e3d2493b5a0109349490eed526baf3e49c7763eb33d704f785d6b085728ae5e1f0e4173 SHA512 b4f1e04861efcc67e0d9c678a6dc2d9dc75c872ba1961702825cb2f146f75b3eab80c0992cf14b444ac4fdeca5f084a92f2c543156ed5b1416e5900b86cf71cb
+MISC metadata.xml 324 BLAKE2B 8da3e1442be9222548ab482b68fe4604afba6ab2e5c143d1550f8f92e5f205575bee4fe5efbb7ea680fecb301f1a55b1bc9a5b0942aa26311b898513f954d736 SHA512 6e87e1076ba13e49fa20313e9761cee9628350e718ab871bfd2bab0409f69dc9afa48d7d530540be8af5d7b10d2c7a14269fc70839ae63351a2a3d3f82e1481c
diff --git a/app-vim/vim2hs/metadata.xml b/app-vim/vim2hs/metadata.xml
new file mode 100644
index 000000000000..cf984477fc49
--- /dev/null
+++ b/app-vim/vim2hs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">dag/vim2hs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild b/app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild
new file mode 100644
index 000000000000..9b0f7392446e
--- /dev/null
+++ b/app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin vcs-snapshot
+
+# Commit Date: 16 Apr 2014
+COMMIT="f2afd55704bfe0a2d66e6b270d247e9b8a7b1664"
+
+DESCRIPTION="vim plugin: collection of vimscripts for Haskell development"
+HOMEPAGE="https://github.com/dag/vim2hs"
+SRC_URI="https://github.com/dag/vim2hs/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/ghc"
+
+src_compile() { :; }
+
+src_install() {
+ # We want a stripped-down version of these.
+ local f
+ for f in screenshots/*; do
+ bzip2 -9 "${f}" || die
+ done
+ vim-plugin_src_install
+}