summaryrefslogtreecommitdiff
path: root/app-vim/vim-tmux
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/vim-tmux
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/vim-tmux')
-rw-r--r--app-vim/vim-tmux/Manifest3
-rw-r--r--app-vim/vim-tmux/metadata.xml18
-rw-r--r--app-vim/vim-tmux/vim-tmux-3.0.0.ebuild17
3 files changed, 38 insertions, 0 deletions
diff --git a/app-vim/vim-tmux/Manifest b/app-vim/vim-tmux/Manifest
new file mode 100644
index 000000000000..807453de4b7d
--- /dev/null
+++ b/app-vim/vim-tmux/Manifest
@@ -0,0 +1,3 @@
+DIST vim-tmux-3.0.0.tar.gz 9658 BLAKE2B 188485b4c74e60292aa153693246c9e612cbc4736accb7aafad3ee901084023b3f40374212afe2139c634b8457c2ec871f0cf5e6d02beb69fc3c433f26b8610d SHA512 d251ff07b0702e4f9969d02a9c32924db62f77b71250fda175053883abc35c18932f9869ea0514df1b7acb9cc65f6b39e2b8c640ad77ff36a19ceaa74d13d77b
+EBUILD vim-tmux-3.0.0.ebuild 556 BLAKE2B 4b7af70822955d4135f9d6745b3b4d5210335ff143d6bfe3f6407373e6b9ceb1562fb672ed83fa8051074205c6a4f12daa8ae1ddd5ebb388509ca3a44dca97b4 SHA512 2ca554af0c52d9af4e9f57d47d2d05b1848350b6fca2e580190dc2d7b0a485094735de2be99d6a942881363ae6178529a6f9356be7b49b4aa7f934ed14522cff
+MISC metadata.xml 556 BLAKE2B e9419237fa1f3b2b3c15d1adf7ca5afdc0da4a1fd051a4b46d839a67079170487c85e05e121c64b4ec4cc82064e217898831db1ed0a2018c345b227c44554ebe SHA512 181979dee06b24a1d4f1b3b325558c628fcdb0ee4d628c7002777f7e460e8a35026f021bb21c79db243fd067d16168c7db804a33c10be0c59f6bb22d46cbf9a9
diff --git a/app-vim/vim-tmux/metadata.xml b/app-vim/vim-tmux/metadata.xml
new file mode 100644
index 000000000000..2e81ab74af54
--- /dev/null
+++ b/app-vim/vim-tmux/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Tools Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tmux-plugins/vim-tmux</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vim-tmux/vim-tmux-3.0.0.ebuild b/app-vim/vim-tmux/vim-tmux-3.0.0.ebuild
new file mode 100644
index 000000000000..ab382fc6fe5a
--- /dev/null
+++ b/app-vim/vim-tmux/vim-tmux-3.0.0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: tmux support for vim"
+HOMEPAGE="https://github.com/tmux-plugins/vim-tmux"
+SRC_URI="https://github.com/tmux-plugins/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim.org"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-fbsd"
+
+# Bug 603526.
+# Remove this line once this version is marked stable
+# and the old ones are gone.
+RDEPEND="!<app-misc/tmux-2.5-r2"