summaryrefslogtreecommitdiff
path: root/app-vim/vim-tmux
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/vim-tmux
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/vim-tmux')
-rw-r--r--app-vim/vim-tmux/Manifest4
-rw-r--r--app-vim/vim-tmux/metadata.xml18
-rw-r--r--app-vim/vim-tmux/vim-tmux-3.0.0.ebuild17
3 files changed, 39 insertions, 0 deletions
diff --git a/app-vim/vim-tmux/Manifest b/app-vim/vim-tmux/Manifest
new file mode 100644
index 000000000000..5b055d8e3fba
--- /dev/null
+++ b/app-vim/vim-tmux/Manifest
@@ -0,0 +1,4 @@
+DIST vim-tmux-3.0.0.zip 12713 SHA256 8ca059d610489a7d8be010aa1136c2501cbe18e86b0552e173fc0a5b6694dc24 SHA512 d6bc94c34ab32608610fdfffc3a3522b6056b3b61dd3cb9c63a71cb20d1597954aec65a06c5ce22352731d4e70b6a239ca5f303427182cce93324042b7f10c8c WHIRLPOOL 49f5b3e9b6e7d4608c049684605b393686c5f1ab447a71ac4af5c6b208829ab5df7f053eaa3bd8b327e6f9d5bd8d0af1547da8a47e89873325d3328ee42830bb
+EBUILD vim-tmux-3.0.0.ebuild 538 SHA256 23d01c0e533e70d38f19b7e0c11e36d3b07d278d4fdaa42414b1afd2e0738041 SHA512 58af16f82a16436e2c993d342666a8cfd2d05728081f7aea53b9c5b22346a83c0d8aeb07637c044678e16904622913ed93369e49018fbfd47199c7941e90339a WHIRLPOOL d37adfcfadd474442f5855d85bcb366c2df3dc80eecee8c66c1b33930395c658495dfde403636fdcd65c5ccc3ce6abdf2bbc954e7660fea04d8a58aae9ebe576
+MISC ChangeLog 622 SHA256 9d76a754efc20e43771cb60034cb4ed378cffc8a86ce221dee0337acfdd28687 SHA512 f002c84049dc62fcff1c70da02621f4d3e337204f2bdb7a7d3f10e5552280ac4c913dc9a994a01725433717fa9dc05f7eb16854caceebd93cdeb672209fa788e WHIRLPOOL 622bc6de357eaf58790d75ebfb71a957922e53a5ec40bf643bae010c3e0ef59fbf6c3b1d2f2ef95ed5dfd8c91993c6c64e6b99875a13242cb74a46c7b5f82e4f
+MISC metadata.xml 556 SHA256 a3ba40e558ce9377d27f02609691978ce6f9ffe0e065dcd7742d87ce6bf0cab6 SHA512 181979dee06b24a1d4f1b3b325558c628fcdb0ee4d628c7002777f7e460e8a35026f021bb21c79db243fd067d16168c7db804a33c10be0c59f6bb22d46cbf9a9 WHIRLPOOL b3ea09c226254badd532db93e3019afbad7378e3ff39e5d568a0920079d8482e6ae2c2414ebb7e4d0c32cf3b0736c46bf2411d3826def0829611c905383a34fc
diff --git a/app-vim/vim-tmux/metadata.xml b/app-vim/vim-tmux/metadata.xml
new file mode 100644
index 000000000000..2e81ab74af54
--- /dev/null
+++ b/app-vim/vim-tmux/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Tools Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tmux-plugins/vim-tmux</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vim-tmux/vim-tmux-3.0.0.ebuild b/app-vim/vim-tmux/vim-tmux-3.0.0.ebuild
new file mode 100644
index 000000000000..21c876b7995e
--- /dev/null
+++ b/app-vim/vim-tmux/vim-tmux-3.0.0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: tmux support for vim"
+HOMEPAGE="https://github.com/tmux-plugins/vim-tmux"
+SRC_URI="https://github.com/tmux-plugins/${PN}/archive/v${PV}.zip -> ${P}.zip"
+LICENSE="vim.org"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~sparc x86"
+
+# Bug 603526.
+# Remove this line once this version is marked stable
+# and the old ones are gone.
+RDEPEND="!<app-misc/tmux-2.5-r2"