summaryrefslogtreecommitdiff
path: root/app-vim/vim-nftables
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /app-vim/vim-nftables
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'app-vim/vim-nftables')
-rw-r--r--app-vim/vim-nftables/Manifest3
-rw-r--r--app-vim/vim-nftables/metadata.xml11
-rw-r--r--app-vim/vim-nftables/vim-nftables-0_pre20200224.ebuild23
3 files changed, 37 insertions, 0 deletions
diff --git a/app-vim/vim-nftables/Manifest b/app-vim/vim-nftables/Manifest
new file mode 100644
index 000000000000..8bd931a9cce7
--- /dev/null
+++ b/app-vim/vim-nftables/Manifest
@@ -0,0 +1,3 @@
+DIST vim-nftables-0_pre20200224.tar.gz 2427 BLAKE2B a17780ffcabd1d323f3ccaa52e9726c2d8dc04583003fd8eaa799c897d1ccb1718a2ef28c2c06f0108785bdcc90addfb27d54f73db8d9f59b225e34c244cf179 SHA512 05dab5d9bdaed4ae1de9e00f2d6996f4350d859af73062d00417ee6567041c0a3fa6f50996fefa64e7a2410779b254ddeac1d5a893aa2f664504278b67fa2fd9
+EBUILD vim-nftables-0_pre20200224.ebuild 502 BLAKE2B 164a3201498bc9d2b9731257ec26c0fb7791a2c339c1a91e00d21dae349a902b415e5792c0bec89e5a2672681118ecca27a7c375cb584dece249e4b3c7b96a73 SHA512 26c2c3f39c08a4ac8ea2c5c63ceb62484bde70b847b6d4d013a56253955c4a9ee3a304dd612b8e2d6529ed8f677f04517069efc4d6a489f18d80a4a5b031830c
+MISC metadata.xml 335 BLAKE2B e6d888e72998d7db2b4e8edfaeaa8de23bab3f0219feb2417efbbfc2eed225a462e261ba50330930e2b7f2dcbfba24423a6e7ed45c663e39c4a4d572f95e61e6 SHA512 6e1a94c30c49afdd2b7183033fac6c3dd47dd5bb6863a572a03634ec2f44ad520465b2cb1d677681ba23fc1235f3f5269b0783923f1d012ba5ab55e29dd2eef1
diff --git a/app-vim/vim-nftables/metadata.xml b/app-vim/vim-nftables/metadata.xml
new file mode 100644
index 000000000000..0172dae3d8ef
--- /dev/null
+++ b/app-vim/vim-nftables/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/vim-nftables/vim-nftables-0_pre20200224.ebuild b/app-vim/vim-nftables/vim-nftables-0_pre20200224.ebuild
new file mode 100644
index 000000000000..733427968a90
--- /dev/null
+++ b/app-vim/vim-nftables/vim-nftables-0_pre20200224.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+COMMIT_ID="01c7b97eff12fd4b624e6efa2c0468163db61ebc"
+
+DESCRIPTION="vim plugin: "
+HOMEPAGE="https://github.com/nfnty/vim-nftables"
+SRC_URI="https://github.com/nfnty/${PN}/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT_ID}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+
+ # will install license file by default
+ rm LICENSE || die
+}