summaryrefslogtreecommitdiff
path: root/app-vim/vim-multiple-cursors
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/vim-multiple-cursors
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/vim-multiple-cursors')
-rw-r--r--app-vim/vim-multiple-cursors/Manifest3
-rw-r--r--app-vim/vim-multiple-cursors/metadata.xml15
-rw-r--r--app-vim/vim-multiple-cursors/vim-multiple-cursors-2.2-r1.ebuild24
3 files changed, 42 insertions, 0 deletions
diff --git a/app-vim/vim-multiple-cursors/Manifest b/app-vim/vim-multiple-cursors/Manifest
new file mode 100644
index 000000000000..fb08c7bf4c02
--- /dev/null
+++ b/app-vim/vim-multiple-cursors/Manifest
@@ -0,0 +1,3 @@
+DIST vim-multiple-cursors-2.2.tar.gz 1055659 SHA256 754d81183d9ef2d17801f9f5518f3343f33ff199f9f602fbae93f6d43f29d9e7 SHA512 109e8117a692e05c450ba30e0a4f635bfd24f08125d06b22c0e850e03e89e193e2ef7b415c8356d326b44ca93254b390d44ee417e8a0ee59fe9a805cf157c0e0 WHIRLPOOL 2856c3a826728e3bdd665c12c8746b97918a722df76252fae255e7fb7dc378a242bb788091453b7f34e5c0437f9a99ffed44426eae1b30bb35f77bb55482d201
+EBUILD vim-multiple-cursors-2.2-r1.ebuild 694 SHA256 ac258feffce70625cf083ee2e51c738fb6777878fad7e177e33e14c1ac91aec5 SHA512 2d8c4b2c46833706500b83d5b3e8db2d82317726f03c298938de0ae3c255d310c076c080dceb6790a127f35a296b11042463924b16a459a8abbc51266400493b WHIRLPOOL c0d546b8fc185242afb73d9cfc156204e826e7a5e226930c4afc9434de02737d0a4af86374404641420c4ace3639995b46ec9fed06f41040b87df4f4e004d512
+MISC metadata.xml 450 SHA256 5d2b721c1f2ae5eb41cbddc27cf0303aa9d6a2735633c8cdb8a21417fd91b94e SHA512 0294668ca3ce283c851e27bcb6854e8fa1189ebb6daadbf2583b05014b2c34efd31194e114b4d7286641673272b8036da8aa7d7358febb1521927a660044ef97 WHIRLPOOL 69e757b18458489caac865039e48d08dde349f8a87651f31c70709ffc98d8e5fc7e17e4886eeb96971bbb8e001c841ede7959ae43298bf08871744087210ef5a
diff --git a/app-vim/vim-multiple-cursors/metadata.xml b/app-vim/vim-multiple-cursors/metadata.xml
new file mode 100644
index 000000000000..b6f784080ccc
--- /dev/null
+++ b/app-vim/vim-multiple-cursors/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">terryma/vim-multiple-cursors</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vim-multiple-cursors/vim-multiple-cursors-2.2-r1.ebuild b/app-vim/vim-multiple-cursors/vim-multiple-cursors-2.2-r1.ebuild
new file mode 100644
index 000000000000..ebf1fe13f8be
--- /dev/null
+++ b/app-vim/vim-multiple-cursors/vim-multiple-cursors-2.2-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Sublime Text's awesome multiple selection feature for Vim"
+HOMEPAGE="https://github.com/terryma/vim-multiple-cursors"
+SRC_URI="https://github.com/terryma/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+src_install() {
+ default
+ vim-plugin_src_install
+ rm -r \
+ "${ED}"/usr/share/vim/vimfiles/spec \
+ "${ED}"/usr/share/vim/vimfiles/assets \
+ "${ED}"/usr/share/doc/${PF}/MIT-LICENSE.txt \
+ "${ED}"/usr/share/doc/${PF}/Rakefile \
+ "${ED}"/usr/share/doc/${PF}/Gemfile.lock \
+ || die "rm failed"
+}