summaryrefslogtreecommitdiff
path: root/app-vim/vim-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/vim-misc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/vim-misc')
-rw-r--r--app-vim/vim-misc/Manifest3
-rw-r--r--app-vim/vim-misc/metadata.xml11
-rw-r--r--app-vim/vim-misc/vim-misc-1.17.6.ebuild18
3 files changed, 32 insertions, 0 deletions
diff --git a/app-vim/vim-misc/Manifest b/app-vim/vim-misc/Manifest
new file mode 100644
index 000000000000..fb24b0967910
--- /dev/null
+++ b/app-vim/vim-misc/Manifest
@@ -0,0 +1,3 @@
+DIST vim-misc-1.17.6.tar.gz 56548 BLAKE2B 59db23c8c272e3e12a8835b9cf9ad5d53be84c4d01d1f8ae3c6c42d55736aed1e018114af1eb14e16b6006a7527addb9a52cf59bf0d42e742b45e9abaa2174ba SHA512 04896559a9179e4f117de4ae78564309c9459ebb78ba1f9aceb7c3abf064e38d403567d01c347eb9ec0a09ed57c8ae51e01c4967e393c58c7b613cf926663e64
+EBUILD vim-misc-1.17.6.ebuild 474 BLAKE2B fba074973a32faf54930c62a1b4a4726bdda03bd075cdcbb7d6a9c00a2b864752dfcbf6b1d79a2e8125be5b49ddd7158b12cbd7404ec137d825a00a756f94856 SHA512 8c5aee37849f8db0fac0d11d1c431a3fc3f78252e77105dc0b52da406db541a08df9277166ef03225fae82eacf35a3b352a906b3fc01a1643490e06ba0f39858
+MISC metadata.xml 338 BLAKE2B 3e043a196cc0c084cf13cc903aba4c820dc1a219c259556d0e9817c0d26979d4ca8536b0a84953869e9e3598bd2dddf5899f7743bcfc373c888b738efa8f5b55 SHA512 c0c91d66a5125ffe1ebd4442bcc808024151a1019e2aaeb64802d3b0a6423ad5b5dcae7956244ffa81a97386f5642434730e11c0bc435fa8a94fa2e8936a5e7d
diff --git a/app-vim/vim-misc/metadata.xml b/app-vim/vim-misc/metadata.xml
new file mode 100644
index 000000000000..fd589251215a
--- /dev/null
+++ b/app-vim/vim-misc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">xolox/vim-misc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vim-misc/vim-misc-1.17.6.ebuild b/app-vim/vim-misc/vim-misc-1.17.6.ebuild
new file mode 100644
index 000000000000..10ce26e479ee
--- /dev/null
+++ b/app-vim/vim-misc/vim-misc-1.17.6.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: miscellaneous auto-load scripts"
+HOMEPAGE="http://peterodding.com/code/vim/misc/"
+SRC_URI="https://github.com/xolox/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+
+VIM_PLUGIN_HELPFILES="misc.txt"
+
+src_prepare() {
+ rm INSTALL.md addon-info.json autoload/xolox/misc/echo.exe || die
+}